summaryrefslogtreecommitdiff
path: root/packages/packagekit/packagekit_git.bb
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-03-11 16:52:37 +0000
committerJohn Lee <john_lee@openmoko.org>2008-03-11 16:52:37 +0000
commit4683d62ca408939ab573237c345ded7b02147cbb (patch)
treeadfaa931c86e07d966cd0feb7ef5a727d8fcd2a9 /packages/packagekit/packagekit_git.bb
parent713e0a97c9115eb9b04b2ab7ee7c48723a614097 (diff)
packagekit: PackageKit is a system designed to make installing and
updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
Diffstat (limited to 'packages/packagekit/packagekit_git.bb')
-rw-r--r--packages/packagekit/packagekit_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/packagekit/packagekit_git.bb b/packages/packagekit/packagekit_git.bb
new file mode 100644
index 0000000000..d4055ead63
--- /dev/null
+++ b/packages/packagekit/packagekit_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "PackageKit package management abstraction"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "dbus (>= 1.1.1) dbus-glib glib-2.0 sqlite3 opkg intltool"
+RDEPENDS = "dbus (>= 1.1.1) dbus-glib glib-2.0 opkg"
+PV = "0.1+git${SRCREV}"
+PR = "r7"
+
+SRC_URI = "git://anongit.freedesktop.org/git/packagekit;protocol=git \
+ file://disable-docbook2man.patch;patch=1"
+
+SRCREV = "${AUTOREV}"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-security-framework=dummy --with-default-backend=opkg --enable-opkg"
+
+do_configure_prepend() {
+ echo "EXTRA_DIST=" > gtk-doc.make
+}
+do_stage () {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/packagekit-backend/*.so ${datadir}/dbus-1/system-services/"