summaryrefslogtreecommitdiff
path: root/packages/orinoco
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2008-01-21 21:09:09 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2008-01-21 21:09:09 +0000
commitafd58cdcce656ced784bfca78d7d96e2edca8cee (patch)
treeb49291fedc042760b35f74afa9b7e82b591147e5 /packages/orinoco
parentac6de0f3c0d8d5fe5708d9125c1319fbf5d627a6 (diff)
parenta7a4c7d6f9bbcda53d3bf07d51142d41e1a4558b (diff)
merge of '1cc9d40e03f431fac4150580f6a58521cae55509'
and 'a250ef0b1707ead866fe051ca88c56e538d51bfb'
Diffstat (limited to 'packages/orinoco')
-rw-r--r--packages/orinoco/orinoco-modules.inc22
-rw-r--r--packages/orinoco/orinoco-modules_0.13e.bb24
-rw-r--r--packages/orinoco/orinoco-modules_0.15rc1.bb25
-rw-r--r--packages/orinoco/orinoco-modules_0.15rc2.bb28
-rw-r--r--packages/orinoco/orinoco-modules_cvs.bb25
5 files changed, 43 insertions, 81 deletions
diff --git a/packages/orinoco/orinoco-modules.inc b/packages/orinoco/orinoco-modules.inc
new file mode 100644
index 0000000000..dcf87ffcfb
--- /dev/null
+++ b/packages/orinoco/orinoco-modules.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
+Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+RDEPENDS_orinoco-modules-pci = "orinoco-modules"
+RDEPENDS_orinoco-modules-usb = "orinoco-modules"
+RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
+RRECOMMENDS_orinoco-modules-cs = "apm-wifi-suspendfix"
+PROVIDES = "spectrum-modules"
+LICENSE = "GPL"
+
+SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz"
+S = "${WORKDIR}/orinoco-${PV}"
+
+inherit module
+
+PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
+FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
+FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
+FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
+ /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
+FILES_orinoco-modules = "/lib/modules/"
diff --git a/packages/orinoco/orinoco-modules_0.13e.bb b/packages/orinoco/orinoco-modules_0.13e.bb
index 9c5cc2f776..4f8ca98e0b 100644
--- a/packages/orinoco/orinoco-modules_0.13e.bb
+++ b/packages/orinoco/orinoco-modules_0.13e.bb
@@ -1,11 +1,9 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-LICENSE = "GPL"
-PR = "r4"
+require orinoco-modules.inc
-SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz; \
+RDEPENDS_orinoco-modules-cs += "orinoco-modules"
+PR = "r5"
+
+SRC_URI += "\
file://crosscompile.patch;patch=1 \
file://monitor-${PV}.patch;patch=1 \
file://spectrum.conf \
@@ -14,8 +12,6 @@ SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz; \
file://orinoco_cs.conf"
S = "${WORKDIR}/orinoco-${PV}"
-inherit module
-
do_compile_prepend() {
cp -f ${WORKDIR}/spectrum* ${S}/
}
@@ -30,14 +26,4 @@ do_install() {
install -m 0644 ${WORKDIR}/orinoco_cs.conf ${D}${sysconfdir}/modutils/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX} /${sysconfdir}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
-RDEPENDS_orinoco-modules-cs = "orinoco-modules"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
diff --git a/packages/orinoco/orinoco-modules_0.15rc1.bb b/packages/orinoco/orinoco-modules_0.15rc1.bb
index ebf0f03bbf..746618f7df 100644
--- a/packages/orinoco/orinoco-modules_0.15rc1.bb
+++ b/packages/orinoco/orinoco-modules_0.15rc1.bb
@@ -1,11 +1,9 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
+require orinoco-modules.inc
+
DEPENDS = "orinoco-conf spectrum-fw"
-RDEPENDS = "orinoco-conf"
-LICENSE = "GPL"
-PR = "r7"
+RDEPENDS += "orinoco-conf"
+RDEPENDS_orinoco-modules-cs += "orinoco-modules spectrum-fw"
+PR = "r8"
SRC_URI = "${SOURCEFORGE_MIRROR}/orinoco/orinoco-${PV}.tar.gz \
file://makefile_fix.patch;patch=1 \
@@ -13,23 +11,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/orinoco/orinoco-${PV}.tar.gz \
file://add_event.patch;patch=1 \
file://add_utsname.patch;patch=1 \
file://spectrum_cs_ids.patch;patch=1"
-S = "${WORKDIR}/orinoco-${PV}"
-
-inherit module
do_install() {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
-RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
diff --git a/packages/orinoco/orinoco-modules_0.15rc2.bb b/packages/orinoco/orinoco-modules_0.15rc2.bb
index 4153e8c4fc..da25d7b7e5 100644
--- a/packages/orinoco/orinoco-modules_0.15rc2.bb
+++ b/packages/orinoco/orinoco-modules_0.15rc2.bb
@@ -1,37 +1,21 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-PROVIDES = "spectrum-modules"
+require orinoco-modules.inc
+
DEPENDS = "orinoco-conf spectrum-fw"
-RDEPENDS = "orinoco-conf"
-LICENSE = "GPL"
-PR = "r9"
+RDEPENDS += "orinoco-conf"
+RDEPENDS_orinoco-modules-cs += "orinoco-modules spectrum-fw"
+PR = "r10"
-SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz \
+SRC_URI += "\
file://makefile_fix.patch;patch=1 \
file://list-move.patch;patch=1 \
file://add_utsname.patch;patch=1 \
file://add_event.patch;patch=1 \
file://spectrum_cs_ids.patch;patch=1 \
file://catch-up-with-kernel-changes.patch;patch=1"
-S = "${WORKDIR}/orinoco-${PV}"
-
-inherit module
do_install() {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
-RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"
diff --git a/packages/orinoco/orinoco-modules_cvs.bb b/packages/orinoco/orinoco-modules_cvs.bb
index 5d3efec80f..6cbb7eb8f6 100644
--- a/packages/orinoco/orinoco-modules_cvs.bb
+++ b/packages/orinoco/orinoco-modules_cvs.bb
@@ -1,12 +1,9 @@
-DESCRIPTION = "A driver for wireless LAN cards based on Hermes(Orinoco) cards. \
-Also contains support for cards using downloadable firmware, i.e. the Symbol/Socket family."
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-PROVIDES = "spectrum-modules"
+require orinoco-modules.inc
+
DEPENDS = "orinoco-conf spectrum-fw"
-RDEPENDS = "orinoco-conf"
-LICENSE = "GPL"
-PR = "r2"
+RDEPENDS += "orinoco-conf"
+RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
+PR = "r3"
PARALLEL_MAKE = ""
EXTRA_OEMAKE = 'KERNEL_SRC="${KERNEL_STAGING_DIR}"'
@@ -18,21 +15,9 @@ SRC_URI = "cvs://anonymous@cvs.sv.gnu.org/cvsroot/orinoco;module=orinoco;method=
file://list-move.patch;patch=1"
S = "${WORKDIR}/orinoco"
-inherit module
-
do_install() {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
}
-PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
- /lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
-FILES_orinoco-modules = "/lib/modules/"
-RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
-RDEPENDS_orinoco-modules-pci = "orinoco-modules"
-RDEPENDS_orinoco-modules-usb = "orinoco-modules"
-RDEPENDS_orinoco-modules-nortel = "orinoco-modules"