summaryrefslogtreecommitdiff
path: root/packages/oprofile/oprofile_0.9.3.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-08-08 17:06:27 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-08-08 17:06:27 +0000
commit89f4a812b9defa0977d3c2fa3416a96a2772a92b (patch)
tree48df21f21eb976a39801d2134c9eaac1015b45ef /packages/oprofile/oprofile_0.9.3.bb
parentf2bfdec5ff7076060a95daa21922374cfa4ef9c4 (diff)
parentb6cea476b9e88669253d1e8761c8f3f118d91228 (diff)
merge of '445066af3cf565c9d88cd6187570272cfa926958'
and '76d3b20f964cec7e37a6e3a20c6298ed35aee629'
Diffstat (limited to 'packages/oprofile/oprofile_0.9.3.bb')
-rw-r--r--packages/oprofile/oprofile_0.9.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/oprofile/oprofile_0.9.3.bb b/packages/oprofile/oprofile_0.9.3.bb
new file mode 100644
index 0000000000..d758b97549
--- /dev/null
+++ b/packages/oprofile/oprofile_0.9.3.bb
@@ -0,0 +1,38 @@
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+DEPENDS = "popt binutils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+ file://acinclude.m4"
+S = "${WORKDIR}/oprofile-${PV}"
+
+inherit autotools
+
+# NOTE: this disables the build of the kernel modules.
+# Should add the oprofile kernel modules, for those with 2.4
+# kernels, as a seperate .oe file.
+EXTRA_OECONF = "--with-kernel-support \
+ --without-x \
+ --disable-werror "
+
+do_configure () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+# Available config options
+# --enable-abi enable abi portability code (default is disabled)
+# --enable-pch enable precompiled header (default is disabled)
+# --enable-gcov enable option for gcov coverage testing (default is disabled)
+# --disable-werror disable -Werror flag (default is enabled for non-release)
+# --disable-optimization disable optimization flags (default is enabled)
+# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
+# --with-linux=dir Path to Linux source tree
+# --with-module-dir=dir Path to module installation directory
+# --with-extra-includes=DIR add extra include paths
+# --with-extra-libs=DIR add extra library paths
+# --with-x use the X Window System
+# --with-qt-dir where the root of Qt is installed
+# --with-qt-includes where the Qt includes are.
+# --with-qt-libraries where the Qt library is installed.