summaryrefslogtreecommitdiff
path: root/packages/openssh/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/openssh/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/openssh/files')
-rw-r--r--packages/openssh/files/init88
-rw-r--r--packages/openssh/files/scp-nossl.patch24
-rw-r--r--packages/openssh/files/sftp-server-nolibcrypto.patch13
3 files changed, 0 insertions, 125 deletions
diff --git a/packages/openssh/files/init b/packages/openssh/files/init
deleted file mode 100644
index b16cbd61a6..0000000000
--- a/packages/openssh/files/init
+++ /dev/null
@@ -1,88 +0,0 @@
-#! /bin/sh
-set -e
-
-# /etc/init.d/ssh: start and stop the OpenBSD "secure shell" daemon
-
-test -x /usr/sbin/sshd || exit 0
-( /usr/sbin/sshd -\? 2>&1 | grep -q OpenSSH ) 2>/dev/null || exit 0
-
-if test -f /etc/default/ssh; then
- . /etc/default/ssh
-fi
-
-check_for_no_start() {
- # forget it if we're trying to start, and /etc/ssh/sshd_not_to_be_run exists
- if [ -e /etc/ssh/sshd_not_to_be_run ]; then
- echo "OpenBSD Secure Shell server not in use (/etc/ssh/sshd_not_to_be_run)"
- exit 0
- fi
-}
-
-check_privsep_dir() {
- # Create the PrivSep empty dir if necessary
- if [ ! -d /var/run/sshd ]; then
- mkdir /var/run/sshd
- chmod 0755 /var/run/sshd
- fi
-}
-
-check_config() {
- /usr/sbin/sshd -t || exit 1
-}
-
-check_keys() {
- # create keys if necessary
- if [ ! -f /etc/ssh/ssh_host_rsa_key ]; then
- echo " generating ssh RSA key..."
- ssh-keygen -q -f /etc/ssh/ssh_host_rsa_key -N '' -t rsa
- fi
- if [ ! -f /etc/ssh/ssh_host_dsa_key ]; then
- echo " generating ssh DSA key..."
- ssh-keygen -q -f /etc/ssh/ssh_host_dsa_key -N '' -t dsa
- fi
-}
-
-export PATH="${PATH:+$PATH:}/usr/sbin:/sbin"
-
-case "$1" in
- start)
- check_for_no_start
- echo "Starting OpenBSD Secure Shell server: sshd"
- check_keys
- check_privsep_dir
- start-stop-daemon -S -x /usr/sbin/sshd -- $SSHD_OPTS
- echo "done."
- ;;
- stop)
- echo -n "Stopping OpenBSD Secure Shell server: sshd"
- start-stop-daemon -K -x /usr/sbin/sshd
- echo "."
- ;;
-
- reload|force-reload)
- check_for_no_start
- check_keys
- check_config
- echo -n "Reloading OpenBSD Secure Shell server's configuration"
- start-stop-daemon -K -s 1 -x /usr/sbin/sshd
- echo "."
- ;;
-
- restart)
- check_keys
- check_config
- echo -n "Restarting OpenBSD Secure Shell server: sshd"
- start-stop-daemon -K -x /usr/sbin/sshd
- check_for_no_start
- check_privsep_dir
- sleep 2
- start-stop-daemon -S -x /usr/sbin/sshd -- $SSHD_OPTS
- echo "."
- ;;
-
- *)
- echo "Usage: /etc/init.d/ssh {start|stop|reload|force-reload|restart}"
- exit 1
-esac
-
-exit 0
diff --git a/packages/openssh/files/scp-nossl.patch b/packages/openssh/files/scp-nossl.patch
deleted file mode 100644
index 222a52ff8a..0000000000
--- a/packages/openssh/files/scp-nossl.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-
-#
-# Made by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- openssh-3.6.1p2/Makefile.in~scp-nossl
-+++ openssh-3.6.1p2/Makefile.in
-@@ -43,6 +43,7 @@
- CFLAGS=@CFLAGS@
- CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
- LIBS=@LIBS@
-+SCP_LIBS=
- LIBPAM=@LIBPAM@
- LIBWRAP=@LIBWRAP@
- AR=@AR@
-@@ -134,7 +135,7 @@
- $(LD) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBWRAP) $(LIBPAM) $(LIBS)
-
- scp$(EXEEXT): $(LIBCOMPAT) libssh.a scp.o progressmeter.o
-- $(LD) -o $@ scp.o progressmeter.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
-+ $(LD) -o $@ scp.o progressmeter.o $(LDFLAGS) -lssh -lopenbsd-compat $(SCP_LIBS)
-
- ssh-add$(EXEEXT): $(LIBCOMPAT) libssh.a ssh-add.o
- $(LD) -o $@ ssh-add.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
diff --git a/packages/openssh/files/sftp-server-nolibcrypto.patch b/packages/openssh/files/sftp-server-nolibcrypto.patch
deleted file mode 100644
index 1b00bff663..0000000000
--- a/packages/openssh/files/sftp-server-nolibcrypto.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: openssh-4.6p1/Makefile.in
-===================================================================
---- openssh-4.6p1.orig/Makefile.in 2007-10-16 11:27:24.000000000 +0100
-+++ openssh-4.6p1/Makefile.in 2007-10-16 11:27:46.000000000 +0100
-@@ -160,7 +160,7 @@
- $(LD) -o $@ ssh-keyscan.o $(LDFLAGS) -lssh -lopenbsd-compat -lssh $(LIBS)
-
- sftp-server$(EXEEXT): $(LIBCOMPAT) libssh.a sftp.o sftp-common.o sftp-server.o
-- $(LD) -o $@ sftp-server.o sftp-common.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
-+ $(LD) -o $@ sftp-server.o sftp-common.o $(LDFLAGS) -lssh -lopenbsd-compat
-
- sftp$(EXEEXT): $(LIBCOMPAT) libssh.a sftp.o sftp-client.o sftp-common.o sftp-glob.o progressmeter.o
- $(LD) -o $@ progressmeter.o sftp.o sftp-client.o sftp-common.o sftp-glob.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS) $(LIBEDIT)