summaryrefslogtreecommitdiff
path: root/packages/opensp/opensp-native_1.5.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2007-12-31 11:50:13 +0000
committerRobert Schuster <thebohemian@gmx.net>2007-12-31 11:50:13 +0000
commit4875f9bd2c47f8cdc40c5fd70012e262f8be4934 (patch)
tree9ca93b2b8e7c1b6dd091490ad33119df0e4fe4f0 /packages/opensp/opensp-native_1.5.bb
parent275f358d054ba5c4721cfe87edaec8202ee8095e (diff)
PR 3656
docbook-dsssl-stylesheets-native: New recipe. docbook-sgml-dtd-native: New recipe. docbook-utils-native 0.6.14: Added recipe for new version. docbook-utils 0.6.14: Added recipe for new version. openjade-native: Made functional from native staging location - fixed compilation error opensp-native: Made functional from native staging location. sgml-common-native 0.6.3: Made functional from native staging location. sgml-common 0.6.3: Added pkginstall and pkgpostinstall.
Diffstat (limited to 'packages/opensp/opensp-native_1.5.bb')
-rw-r--r--packages/opensp/opensp-native_1.5.bb21
1 files changed, 18 insertions, 3 deletions
diff --git a/packages/opensp/opensp-native_1.5.bb b/packages/opensp/opensp-native_1.5.bb
index e0194c5798..f837ec908a 100644
--- a/packages/opensp/opensp-native_1.5.bb
+++ b/packages/opensp/opensp-native_1.5.bb
@@ -3,13 +3,19 @@ DEPENDS = ""
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \
- file://m4.patch;patch=1 \
- file://attributevalue.patch;patch=1 \
- file://rangmap-fix.patch;patch=1"
+ file://m4.patch;patch=1 \
+ file://attributevalue.patch;patch=1 \
+ file://rangmap-fix.patch;patch=1"
+
S = "${WORKDIR}/OpenSP-${PV}"
LICENSE = "MIT"
inherit autotools native
+EXTRA_OECONF = "\
+ --enable-default-catalog=${sysconfdir}/sgml/catalog \
+ --enable-default-search-path=${datadir}/sgml \
+ "
+
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/opensp-${PV}"
PACKAGES = ""
@@ -24,4 +30,13 @@ do_stage () {
install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/OpenSP/
install -m 0644 ${S}/include/*.cxx ${STAGING_INCDIR}/OpenSP/
install -m 0644 config.h ${STAGING_INCDIR}/OpenSP/config.h
+
+ # Installs all the tools and symlink with another common name to each.
+ install -d ${STAGING_BINDIR_NATIVE}
+ for tool in nsgmls sgmlnorm spam spcat spent sx
+ do
+ echo installing $tool to ${STAGING_BINDIR_NATIVE}
+ install -m 0755 $tool/.libs/o$tool ${STAGING_BINDIR_NATIVE}
+ ln -sf o$tool ${STAGING_BINDIR_NATIVE}/$tool
+ done
}