summaryrefslogtreecommitdiff
path: root/packages/openslug-init
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-18 19:40:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-18 19:40:57 +0000
commit7279d75be5455744430a3126ab800062375b38bf (patch)
tree3c1dc1e4113e201015f9dfeb4649b1ce79a74e32 /packages/openslug-init
parent04a269c583bc9586020846c8668d847b5de6095f (diff)
Fix for slugbug 197. This no longer runs udhcp to get the network address
if /etc/default/sysconf has bootproto=static This affects network boot (nfs) only - previously a DHCP address would be used in preference to the specified static one. All NFS root users please test this - the number of failure cases are large and a failure may leave the system unbootable.
Diffstat (limited to 'packages/openslug-init')
-rwxr-xr-xpackages/openslug-init/openslug-init-0.10/functions11
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb2
2 files changed, 8 insertions, 5 deletions
diff --git a/packages/openslug-init/openslug-init-0.10/functions b/packages/openslug-init/openslug-init-0.10/functions
index ac8e195abd..61b5eb2776 100755
--- a/packages/openslug-init/openslug-init-0.10/functions
+++ b/packages/openslug-init/openslug-init-0.10/functions
@@ -209,10 +209,13 @@ ifup(){
# is not left running so this will only work for
# the lease length time!
ifconfig "$iface" up
- test -n "$hostname" && HOSTNAME="-H $hostname"
- # The script writes the required shell variable assignments
- # to file descriptor 9
- eval $(udhcpc -i "$iface" -n -q -r "$ip" $HOSTNAME -s /boot/udhcpc.script 9>&1 >/dev/null)
+ if test "$(config boot)" != static
+ then
+ test -n "$hostname" && HOSTNAME="-H $hostname"
+ # The script writes the required shell variable assignments
+ # to file descriptor 9
+ eval $(udhcpc -i "$iface" -n -q -r "$ip" $HOSTNAME -s /boot/udhcpc.script 9>&1 >/dev/null)
+ fi
test -n "$broadcast" && BROADCAST="broadcast $broadcast"
test -n "$subnet" && NETMASK="netmask $subnet"
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index 59b8c0fd5d..60726d8dc2 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -3,7 +3,7 @@ SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r38"
+PR = "r39"
SRC_URI = "file://linuxrc \
file://boot/flash \