summaryrefslogtreecommitdiff
path: root/packages/openslug-init
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2005-07-17 13:15:49 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-17 13:15:49 +0000
commit04a269c583bc9586020846c8668d847b5de6095f (patch)
treecaa1b30aa5548b9f44e99043787c0b30b26ae105 /packages/openslug-init
parentdb5f69fd2cc3ca3053b899237dfde27ed9134950 (diff)
parent3143c04f905275f5f07c4147c914e7f859b5fd7d (diff)
merge of e74c73570c2c682aebf3f9050ed959e4f615d79e
and efd8c005871477b3c2788c1257799459527dd028
Diffstat (limited to 'packages/openslug-init')
-rw-r--r--packages/openslug-init/openslug-init-0.10/initscripts/umountinitrd.sh17
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb2
2 files changed, 16 insertions, 3 deletions
diff --git a/packages/openslug-init/openslug-init-0.10/initscripts/umountinitrd.sh b/packages/openslug-init/openslug-init-0.10/initscripts/umountinitrd.sh
index b7ae8b76e5..da39b425f8 100644
--- a/packages/openslug-init/openslug-init-0.10/initscripts/umountinitrd.sh
+++ b/packages/openslug-init/openslug-init-0.10/initscripts/umountinitrd.sh
@@ -1,5 +1,18 @@
#!/bin/sh
#
# umount /mnt, which is where the initrd ends up mounted
-# if the directory /initrd is not present
-exec umount /mnt 2>/dev/null
+# if the directory /initrd is not present, if this fails
+# then the /initrd is mounted and we want to remount that
+# ro - this works round the shutdown -r hang problem
+umount /mnt 2>/dev/null || {
+ # need the device for a remount
+ . /etc/default/functions
+ ffspart=Flashdisk
+ ffsdev="$(mtblockdev $ffspart)"
+ if test -n "$ffsdev" -a -b "$ffsdev"
+ then
+ mount -o remount,ro "$ffsdev" /initrd
+ else
+ echo "Flashdisk: $ffsdev: flash device not found" >&2
+ fi
+}
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index 537760f8d5..59b8c0fd5d 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -3,7 +3,7 @@ SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r37"
+PR = "r38"
SRC_URI = "file://linuxrc \
file://boot/flash \