summaryrefslogtreecommitdiff
path: root/packages/openslug-init/openslug-init_0.10.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-05-30 06:12:33 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-05-30 06:12:33 +0000
commit6950e496815f69df7b50f4664b654ac6b3e4f7de (patch)
tree0cd12f2251a5a0590d3c511d60d8a26dc10575e9 /packages/openslug-init/openslug-init_0.10.bb
parenta4912c88f3ebe4f5e322773b655b4300f1e39e07 (diff)
Initscripts patch.
This changes the order of the shutdown scripts in openslug to ensure that the network shutdown does not happen before network file systems have been unmounted. It also adds some missing scripts - hwclock.sh (load/save the hwclock, otherwise it gets loaded but not saved, in the absence of NTP). alignment.sh (added to openslug, was in 'arm' before), and umountfs (excluded from oe). The file system unmount scripts use /proc/mounts (not fstab) and unmount in the correct order (the old scripts only worked if nothing was mounted within a mounted file system). Scripts have been patched (openslug only patches) to make them work correctly with openslug NFS, flash and disk root and to arrange for syslog to run as long as possible (it's now in S/0/6, not in the user run levels). Directory struction of openslug-init has been tidied up, with all the initscripts in a sub-dirctory. initscritps-openslug is an openslug specific variant of initscripts which tracks it and fails safe (an update/change to initscripts will cause initscripts-openslug to fail rather than build strangeness). turnup also contains a fix for slugbug 150. BKrev: 429aaed1D-1XOdk8brF2bP9C9EEEJQ
Diffstat (limited to 'packages/openslug-init/openslug-init_0.10.bb')
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb46
1 files changed, 31 insertions, 15 deletions
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index be4f02714a..7414a23e99 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "Openslug initial network config via sysconf"
SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files"
-PR = "r26"
+RDEPENDS = "busybox"
+PR = "r27"
SRC_URI = "file://linuxrc \
file://boot/flash \
@@ -11,13 +12,17 @@ SRC_URI = "file://linuxrc \
file://boot/ram \
file://boot/network \
file://boot/udhcpc.script \
+ file://initscripts/syslog.buffer \
+ file://initscripts/syslog.file \
+ file://initscripts/syslog.network \
+ file://initscripts/zleds \
+ file://initscripts/leds_startup \
+ file://initscripts/rmrecovery \
+ file://initscripts/sysconfsetup \
+ file://initscripts/umountinitrd.sh \
file://functions \
- file://rmrecovery \
- file://sysconfsetup \
file://turnup \
file://modprobe.conf \
- file://leds_rs_green \
- file://leds_startup \
file://leds.h \
file://leds.c \
file://kern_header.c \
@@ -29,6 +34,8 @@ USRSBINPROGS = "kern_header"
CPROGS = "${USRSBINPROGS} ${SBINPROGS}"
SCRIPTS = "turnup update-kernel"
BOOTSCRIPTS = "flash disk nfs ram network udhcpc.script"
+INITSCRIPTS = "syslog.buffer syslog.file syslog.network zleds\
+ leds_startup rmrecovery sysconfsetup umountinitrd.sh"
# This just makes things easier...
S="${WORKDIR}"
@@ -78,10 +85,10 @@ do_install() {
#
# Init scripts
install -m 0644 functions ${D}${sysconfdir}/default
- install -m 0755 rmrecovery ${D}${sysconfdir}/init.d/
- install -m 0755 sysconfsetup ${D}${sysconfdir}/init.d/
- install -m 0755 leds_startup ${D}${sysconfdir}/init.d/
- install -m 0755 leds_rs_green ${D}${sysconfdir}/init.d/zleds_rs
+ for s in ${INITSCRIPTS}
+ do
+ install -m 0755 initscripts/$s ${D}${sysconfdir}/init.d/
+ done
#
# Boot scripts
@@ -100,21 +107,30 @@ do_install() {
# case it is normal to run 'start' and 'stop', but because the conf
# files installed don't actually start or stop anything this is
# unnecessary, so the package postfoo handling is simplified here.
+#NB: do not use '08' (etc) for the first argument after start/stop,
+# the value is interpreted as an octal number if there is a leading
+# zero.
pkg_postinst_openslug-init() {
opt=
test -n "$D" && opt="-r $D"
- update-rc.d $opt sysconfsetup start 11 S .
- update-rc.d $opt zleds_rs start 99 S 1 2 3 4 5 . stop 05 0 1 2 3 4 5 6 .
+ update-rc.d $opt hwclock.sh start 8 S . start 45 0 6 .
+ update-rc.d $opt umountinitrd.sh start 9 S .
+ update-rc.d $opt syslog.buffer start 11 S . start 49 0 6 .
+ update-rc.d $opt sysconfsetup start 12 S .
+ update-rc.d $opt syslog.file start 39 S . start 47 0 6 .
+ update-rc.d $opt syslog.network start 44 S . start 39 0 6 .
+ update-rc.d $opt zleds start 99 S 1 2 3 4 5 . stop 5 0 1 2 3 4 5 6 .
# bug fix for startup
- update-rc.d $opt leds_startup start 01 1 2 3 4 5 .
+ update-rc.d $opt leds_startup start 1 1 2 3 4 5 .
}
pkg_postrm_openslug-init() {
opt=
test -n "$D" && opt="-r $D"
- update-rc.d $opt sysconfsetup remove
- update-rc.d $opt zleds_rs remove
- update-rc.d $opt leds_startup remove
+ for s in ${INITSCRIPTS}
+ do
+ update-rc.d $opt "$s" remove
+ done
}
PACKAGES = "${PN}"