summaryrefslogtreecommitdiff
path: root/packages/openpbx/openpbx.org-perl.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-21 13:35:51 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-21 13:35:51 +0000
commit76eb025c76dfc754aa08cd2063f22938a72caf05 (patch)
tree887696a4c71eff8bea00e2c09e160d95bfd08e1e /packages/openpbx/openpbx.org-perl.bb
parentefdccb14f56b5bba31b19617f114f9004bd635c2 (diff)
openpbx.org: Update to use sox-native to create the sounds when building
Diffstat (limited to 'packages/openpbx/openpbx.org-perl.bb')
-rw-r--r--packages/openpbx/openpbx.org-perl.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/openpbx/openpbx.org-perl.bb b/packages/openpbx/openpbx.org-perl.bb
new file mode 100644
index 0000000000..124dfcfc8b
--- /dev/null
+++ b/packages/openpbx/openpbx.org-perl.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Openpbx::OGI Perl Gateway Interface Module"
+HOMEPAGE = "http://www.openpbx.org"
+SECTION = "libs"
+LICENSE = "GPL"
+DEPENDS = "install-native"
+RDEPENDS = "perl openpbx.org-ogi"
+PR = "r0"
+
+OPBXV = "openpbx.org-1.2_rc3"
+
+SRC_URI = "http://www.openpbx.org/releases/${OPBXV}.tar.gz"
+
+S = "${WORKDIR}/${OPBXV}/contrib/ogi-perl/openpbx-perl-${PV}"
+
+inherit cpan
+
+do_install_append () {
+ install -d ${D}${datadir}/openpbx.org/ogi/perl
+ install ${S}/examples/* ${D}${datadir}/openpbx.org/ogi/perl
+}
+
+PACKAGES =+ "${PN}-examples"
+
+FILES_${PN}-examples = "${datadir}/openpbx.org/ogi/perl"