summaryrefslogtreecommitdiff
path: root/packages/openobex/openobex_1.3.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-07-19 22:40:02 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-07-19 22:40:02 +0000
commit5ba491d8e43f191d8543f59057fd00a211aa6217 (patch)
tree5b998d3460f899326028acd9379943f54ba82b88 /packages/openobex/openobex_1.3.bb
parent0fed4443d244760bf7879685d85ea5763ff7bb82 (diff)
parent2e747d3e035660f279e778c606d8f3fd8845feba (diff)
merge of '2d7a4954a028d357fdb005ec7dc50e56f4e997f4'
and 'cde22aa5c39460e2787e0255619a9416ebfb680d'
Diffstat (limited to 'packages/openobex/openobex_1.3.bb')
-rw-r--r--packages/openobex/openobex_1.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/openobex/openobex_1.3.bb b/packages/openobex/openobex_1.3.bb
new file mode 100644
index 0000000000..606f8de1c3
--- /dev/null
+++ b/packages/openobex/openobex_1.3.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez-libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+do_stage() {
+ oe_libinstall -so -C lib libopenobex ${STAGING_LIBDIR}
+ ln -sf libopenobex.so ${STAGING_LIBDIR}/libopenobex-1.2.so
+ install -d ${STAGING_INCDIR}/openobex
+ install -m 0644 include/*.h ${STAGING_INCDIR}/openobex/
+ install -d ${STAGING_DIR}/aclocal
+ install -m 0644 openobex.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"