summaryrefslogtreecommitdiff
path: root/packages/openobex-apps
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/openobex-apps
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/openobex-apps')
-rw-r--r--packages/openobex-apps/.mtn2git_empty0
-rw-r--r--packages/openobex-apps/openobex-apps-1.0.0/.mtn2git_empty0
-rw-r--r--packages/openobex-apps/openobex-apps-1.0.0/gcc34.patch260
-rw-r--r--packages/openobex-apps/openobex-apps-1.0.0/m4.patch64
-rw-r--r--packages/openobex-apps/openobex-apps_1.0.0.bb14
5 files changed, 338 insertions, 0 deletions
diff --git a/packages/openobex-apps/.mtn2git_empty b/packages/openobex-apps/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openobex-apps/.mtn2git_empty
diff --git a/packages/openobex-apps/openobex-apps-1.0.0/.mtn2git_empty b/packages/openobex-apps/openobex-apps-1.0.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openobex-apps/openobex-apps-1.0.0/.mtn2git_empty
diff --git a/packages/openobex-apps/openobex-apps-1.0.0/gcc34.patch b/packages/openobex-apps/openobex-apps-1.0.0/gcc34.patch
index e69de29bb2..6dac1725b6 100644
--- a/packages/openobex-apps/openobex-apps-1.0.0/gcc34.patch
+++ b/packages/openobex-apps/openobex-apps-1.0.0/gcc34.patch
@@ -0,0 +1,260 @@
+diff -Naur openobex-apps-1.0.0-clean/src/obex_put_common.c openobex-apps-1.0.0/src/obex_put_common.c
+--- openobex-apps-1.0.0-clean/src/obex_put_common.c 2002-12-01 18:34:41.000000000 +0100
++++ openobex-apps-1.0.0/src/obex_put_common.c 2004-05-12 12:57:37.000000000 +0200
+@@ -82,7 +82,7 @@
+ break;
+
+ default:
+- printf(__FUNCTION__ "() Skipped header %02x\n", hi);
++ printf("%s() Skipped header %02x\n", __func__, hi);
+ }
+ }
+ if(!body) {
+@@ -123,7 +123,7 @@
+ OBEX_ObjectSetRsp(object, OBEX_RSP_SUCCESS, OBEX_RSP_SUCCESS);
+ break;
+ default:
+- printf(__FUNCTION__ "() Denied %02x request\n", cmd);
++ printf("%s() Denied %02x request\n", __func__, cmd);
+ OBEX_ObjectSetRsp(object, OBEX_RSP_NOT_IMPLEMENTED, OBEX_RSP_NOT_IMPLEMENTED);
+ break;
+ }
+diff -Naur openobex-apps-1.0.0-clean/src/obex_test_cable.h openobex-apps-1.0.0/src/obex_test_cable.h
+--- openobex-apps-1.0.0-clean/src/obex_test_cable.h 2002-12-01 18:34:41.000000000 +0100
++++ openobex-apps-1.0.0/src/obex_test_cable.h 2004-05-12 13:23:11.000000000 +0200
+@@ -1,16 +1,16 @@
+ /*********************************************************************
+- *
++ *
+ * Filename: obex_test_cable.h
+- * Version:
+- * Description:
++ * Version:
++ * Description:
+ * Status: Experimental.
+ * Author: Pontus Fuchs <pontus.fuchs@tactel.se>
+ * Created at: Wed Nov 17 22:05:16 1999
+ * Modified at: Sun Aug 13 10:55:20 PM CEST 2000
+ * Modified by: Pontus Fuchs <pontus.fuchs@tactel.se>
+- *
++ *
+ * Copyright (c) 1999, 2000 Pontus Fuchs, All Rights Reserved.
+- *
++ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+@@ -23,9 +23,9 @@
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+- * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
++ * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+ * MA 02111-1307 USA
+- *
++ *
+ ********************************************************************/
+
+ #ifndef OBEX_TEST_CABLE_H
+@@ -38,7 +38,7 @@
+ #include <openobex/obex.h>
+
+ #ifdef CABLE_DEBUG
+-#define CDEBUG(args...) printf(__FUNCTION__ "() " args)
++#define CDEBUG(args...) printf("%s() ", __func__, args)
+ #else
+ #define CDEBUG(args...)
+ #endif
+diff -Naur openobex-apps-1.0.0-clean/src/obex_test_cable.h~ openobex-apps-1.0.0/src/obex_test_cable.h~
+--- openobex-apps-1.0.0-clean/src/obex_test_cable.h~ 1970-01-01 01:00:00.000000000 +0100
++++ openobex-apps-1.0.0/src/obex_test_cable.h~ 2004-05-12 13:22:48.000000000 +0200
+@@ -0,0 +1,66 @@
++/*********************************************************************
++ *
++ * Filename: obex_test_cable.h
++ * Version:
++ * Description:
++ * Status: Experimental.
++ * Author: Pontus Fuchs <pontus.fuchs@tactel.se>
++ * Created at: Wed Nov 17 22:05:16 1999
++ * Modified at: Sun Aug 13 10:55:20 PM CEST 2000
++ * Modified by: Pontus Fuchs <pontus.fuchs@tactel.se>
++ *
++ * Copyright (c) 1999, 2000 Pontus Fuchs, All Rights Reserved.
++ *
++ * This library is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2 of the License, or (at your option) any later version.
++ *
++ * This library is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU Lesser General Public
++ * License along with this library; if not, write to the Free Software
++ * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
++ * MA 02111-1307 USA
++ *
++ ********************************************************************/
++
++#ifndef OBEX_TEST_CABLE_H
++#define OBEX_TEST_CABLE_H
++
++#define CABLE_DEBUG 1
++
++
++#include <termios.h>
++#include <openobex/obex.h>
++
++#ifdef CABLE_DEBUG
++#define CDEBUG(args...) printf("%s() " __func__, args)
++#else
++#define CDEBUG(args...)
++#endif
++
++struct cobex_context
++{
++ const char *portname;
++ int ttyfd;
++ char inputbuf[500];
++ struct termios oldtio, newtio;
++ int r320;
++};
++
++/* User function */
++struct cobex_context *cobex_open(const char *port, int r320);
++void cobex_close(struct cobex_context *gt);
++int cobex_do_at_cmd(struct cobex_context *gt, char *cmd, char *rspbuf, int rspbuflen, int timeout);
++
++/* Callbacks */
++int cobex_handle_input(obex_t *handle, void * userdata, int timeout);
++int cobex_write(obex_t *self, void * userdata, uint8_t *buffer, int length);
++int cobex_connect(obex_t *handle, void * userdata);
++int cobex_disconnect(obex_t *handle, void * userdata);
++
++#endif
+diff -Naur openobex-apps-1.0.0-clean/src/obex_test_client.c openobex-apps-1.0.0/src/obex_test_client.c
+--- openobex-apps-1.0.0-clean/src/obex_test_client.c 2002-12-01 18:34:41.000000000 +0100
++++ openobex-apps-1.0.0/src/obex_test_client.c 2004-05-12 13:07:24.000000000 +0200
+@@ -370,13 +370,13 @@
+
+ while(OBEX_ObjectGetNextHeader(handle, object, &hi, &hv, &hlen)) {
+ if(hi == OBEX_HDR_BODY) {
+- printf(__FUNCTION__ "() Found body\n");
++ printf("%s() Found body\n", __func__);
+ body = hv.bs;
+ body_len = hlen;
+ break;
+ }
+ else {
+- printf(__FUNCTION__ "() Skipped header %02x\n", hi);
++ printf("%s() Skipped header %02x\n", __func__, hi);
+ }
+ }
+
+diff -Naur openobex-apps-1.0.0-clean/src/obex_test_server.c openobex-apps-1.0.0/src/obex_test_server.c
+--- openobex-apps-1.0.0-clean/src/obex_test_server.c 2002-12-01 18:34:41.000000000 +0100
++++ openobex-apps-1.0.0/src/obex_test_server.c 2004-05-12 13:07:33.000000000 +0200
+@@ -54,17 +54,17 @@
+ char *name = NULL;
+ char *namebuf = NULL;
+
+- printf(__FUNCTION__ "()\n");
++ printf("%s()\n", __func__);
+
+ while(OBEX_ObjectGetNextHeader(handle, object, &hi, &hv, &hlen)) {
+ switch(hi) {
+ case OBEX_HDR_BODY:
+- printf(__FUNCTION__ "() Found body\n");
++ printf("%s() Found body\n", __func__);
+ body = hv.bs;
+ body_len = hlen;
+ break;
+ case OBEX_HDR_NAME:
+- printf(__FUNCTION__ "() Found name\n");
++ printf("%s() Found name\n", __func__);
+ if( (namebuf = malloc(hlen / 2))) {
+ OBEX_UnicodeToChar(namebuf, hv.bs, hlen);
+ name = namebuf;
+@@ -72,7 +72,7 @@
+ break;
+
+ default:
+- printf(__FUNCTION__ "() Skipped header %02x\n", hi);
++ printf("%s() Skipped header %02x\n", __func__, hi);
+ }
+ }
+ if(!body) {
+@@ -103,12 +103,12 @@
+ char *name = NULL;
+ char *namebuf = NULL;
+
+- printf(__FUNCTION__ "()\n");
++ printf("%s()\n", __func__);
+
+ while(OBEX_ObjectGetNextHeader(handle, object, &hi, &hv, &hlen)) {
+ switch(hi) {
+ case OBEX_HDR_NAME:
+- printf(__FUNCTION__ "() Found name\n");
++ printf("%s() Found name\n", __func__);
+ if( (namebuf = malloc(hlen / 2))) {
+ OBEX_UnicodeToChar(namebuf, hv.bs, hlen);
+ name = namebuf;
+@@ -116,16 +116,16 @@
+ break;
+
+ default:
+- printf(__FUNCTION__ "() Skipped header %02x\n", hi);
++ printf("%s() Skipped header %02x\n", __func__, hi);
+ }
+ }
+
+ if(!name) {
+- printf(__FUNCTION__ "() Got a GET without a name-header!\n");
++ printf("%s() Got a GET without a name-header!\n", __func__);
+ OBEX_ObjectSetRsp(object, OBEX_RSP_NOT_FOUND, OBEX_RSP_NOT_FOUND);
+ return;
+ }
+- printf(__FUNCTION__ "() Got a request for %s\n", name);
++ printf("%s() Got a request for %s\n", __func__, name);
+
+ buf = easy_readfile(name, &file_size);
+ if(buf == NULL) {
+@@ -154,7 +154,7 @@
+
+ const uint8_t *who = NULL;
+ int who_len = 0;
+- printf(__FUNCTION__ "()\n");
++ printf("%s()\n", __func__);
+
+ while(OBEX_ObjectGetNextHeader(handle, object, &hi, &hv, &hlen)) {
+ if(hi == OBEX_HDR_WHO) {
+@@ -162,7 +162,7 @@
+ who_len = hlen;
+ }
+ else {
+- printf(__FUNCTION__ "() Skipped header %02x\n", hi);
++ printf("%s() Skipped header %02x\n", __func__, hi);
+ }
+ }
+ if (who_len == 6) {
+@@ -199,7 +199,7 @@
+ OBEX_ObjectSetRsp(object, OBEX_RSP_CONTINUE, OBEX_RSP_SUCCESS);
+ break;
+ default:
+- printf(__FUNCTION__ "() Denied %02x request\n", cmd);
++ printf("%s() Denied %02x request\n", __func__, cmd);
+ OBEX_ObjectSetRsp(object, OBEX_RSP_NOT_IMPLEMENTED, OBEX_RSP_NOT_IMPLEMENTED);
+ break;
+ }
+@@ -224,7 +224,7 @@
+ break;
+
+ default:
+- printf(__FUNCTION__ "() Command (%02x) has now finished\n", obex_cmd);
++ printf("%s() Command (%02x) has now finished\n", __func__, obex_cmd);
+ break;
+ }
+ }
diff --git a/packages/openobex-apps/openobex-apps-1.0.0/m4.patch b/packages/openobex-apps/openobex-apps-1.0.0/m4.patch
index e69de29bb2..249074bf60 100644
--- a/packages/openobex-apps/openobex-apps-1.0.0/m4.patch
+++ b/packages/openobex-apps/openobex-apps-1.0.0/m4.patch
@@ -0,0 +1,64 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null 2003-09-23 18:19:32.000000000 -0400
++++ openobex-apps-1.0.0/m4/openobex.m4 2004-01-26 18:48:04.000000000 -0500
+@@ -0,0 +1,56 @@
++dnl Check for openobex library
++dnl Written by Pontus Fuchs 2000-08-18
++dnl Version checking fixed by Christian W. Zuckschwerdt 2002-10-17
++
++AC_DEFUN([AM_PATH_OPENOBEX], [
++ AC_PATH_PROG(OPENOBEX_CONFIG, openobex-config, no)
++
++ if test "$OPENOBEX_CONFIG" = "no" ; then
++ AC_MSG_ERROR(openobex-config not found. Pehaps openobex is not installed.)
++ fi
++
++ min_obex_version=ifelse([$1], ,0.9.6,$1)
++ AC_MSG_CHECKING(for openobex - version >= $min_obex_version)
++
++ OPENOBEX_CFLAGS=`$OPENOBEX_CONFIG --cflags`
++ OPENOBEX_LIBS=`$OPENOBEX_CONFIG --libs`
++
++ obex_config_version=`$OPENOBEX_CONFIG --version`
++
++ obex_config_major_version=`$OPENOBEX_CONFIG --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ obex_config_minor_version=`$OPENOBEX_CONFIG --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ obex_config_micro_version=`$OPENOBEX_CONFIG --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++
++ obex_req_major_version=`echo $min_obex_version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ obex_req_minor_version=`echo $min_obex_version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ obex_req_micro_version=`echo $min_obex_version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++
++
++ if test $obex_req_major_version -lt $obex_config_major_version ; then
++ obex_config_version_ok="yes"
++ fi
++ if test $obex_req_major_version -eq $obex_config_major_version ; then
++ if test $obex_req_minor_version -lt $obex_config_minor_version ; then
++ obex_config_version_ok="yes"
++ fi
++ if test $obex_req_minor_version -eq $obex_config_minor_version ; then
++ if test $obex_req_micro_version -le $obex_config_micro_version ; then
++ obex_config_version_ok="yes"
++ fi
++ fi
++ fi
++
++ if test "$obex_config_version_ok" != "yes" ; then
++ AC_MSG_ERROR(Installed openobex library too old ($obex_config_version))
++ fi
++
++ AC_SUBST(OPENOBEX_CFLAGS)
++ AC_SUBST(OPENOBEX_LIBS)
++ AC_MSG_RESULT(yes)
++])
diff --git a/packages/openobex-apps/openobex-apps_1.0.0.bb b/packages/openobex-apps/openobex-apps_1.0.0.bb
index e69de29bb2..f7e98538b0 100644
--- a/packages/openobex-apps/openobex-apps_1.0.0.bb
+++ b/packages/openobex-apps/openobex-apps_1.0.0.bb
@@ -0,0 +1,14 @@
+LICENSE = GPL
+DESCRIPTION = "Applications for OpenOBEX"
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "openobex"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-apps-${PV}.tar.gz \
+ file://m4.patch;patch=1 \
+ file://gcc34.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-glibtest --with-glib-prefix=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'INCLUDES='"