summaryrefslogtreecommitdiff
path: root/packages/openntpd/openntpd_3.9p1.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-09-11 08:16:28 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2006-09-11 08:16:28 +0000
commitcdde39f38127046eab328cd0c90b2b36e46423b8 (patch)
tree718f1a3076938675368af5c77d6acf4cca1ee7dc /packages/openntpd/openntpd_3.9p1.bb
parentc686df53390a3e4031deb166c85fe3fb52a6c005 (diff)
openntpd: Upstream upgrade to 3.9p1
Diffstat (limited to 'packages/openntpd/openntpd_3.9p1.bb')
-rw-r--r--packages/openntpd/openntpd_3.9p1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/openntpd/openntpd_3.9p1.bb b/packages/openntpd/openntpd_3.9p1.bb
new file mode 100644
index 0000000000..f7dd0beee2
--- /dev/null
+++ b/packages/openntpd/openntpd_3.9p1.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
+Network Time Protocol."
+HOMEPAGE = "http://www.openntpd.org/"
+SECTION = "console/network"
+MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
+LICENSE = "BSD"
+DEPENDS += "openssl"
+DEPENDS = "timezones"
+PR = "r0"
+
+SRC_URI = "http://www.zip.com.au/~dtucker/openntpd/release/openntpd-${PV}.tar.gz \
+ file://adjtimex-${PV}.patch;patch=1 \
+ file://init"
+
+S = "${WORKDIR}/openntpd-${PV}"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
+ --sysconfdir=/etc --with-privsep-path=/${localstatedir}/shared/empty \
+ --with-privsep-user=ntpd \
+ --with-builtin-arc4random \
+ --without-ssl-dir"
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/init.d
+}
+do_install_append() {
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
+}
+
+pkg_postinst () {
+ [ ! -d ${localstatedir}/shared ] && mkdir -p ${localstatedir}/shared
+ grep ntpd ${sysconfdir}/passwd || adduser --disabled-password --home=${localstatedir}/shared/empty --ingroup nogroup ntpd
+ chown root:root ${localstatedir}/shared/empty
+}
+
+pkg_postrm () {
+ grep ntpd ${sysconfdir}/passwd && deluser ntpd
+}
+
+INITSCRIPT_NAME = "openntpd"
+
+INITSCRIPT_PARAMS = "defaults"