summaryrefslogtreecommitdiff
path: root/packages/openmoko2/openmoko-theme-standard2-qvga_svn.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-09-06 17:57:09 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-09-06 17:57:09 +0000
commitd39ad541854182c47c70071aa6c883ba3480b994 (patch)
tree068ca2b589703211ec9b130e84aa3ffe8cdb81ea /packages/openmoko2/openmoko-theme-standard2-qvga_svn.bb
parentee94da8a579022c9654f3e3659b8f2f243c57bb4 (diff)
parentc5cc423a2ce2c5a1659c171aefcbcec22b768c56 (diff)
merge of '4a859de905afc30ec35cf91dcd1dd6c18307c1f8'
and '9c6ceb61576fa98453a24fedb60c9d2b23d79c72'
Diffstat (limited to 'packages/openmoko2/openmoko-theme-standard2-qvga_svn.bb')
-rw-r--r--packages/openmoko2/openmoko-theme-standard2-qvga_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/openmoko2/openmoko-theme-standard2-qvga_svn.bb b/packages/openmoko2/openmoko-theme-standard2-qvga_svn.bb
new file mode 100644
index 0000000000..6ac1c3fca4
--- /dev/null
+++ b/packages/openmoko2/openmoko-theme-standard2-qvga_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Standard Gtk+ theme for the OpenMoko distribution, QVGA edition"
+SECTION = "openmoko/base"
+RCONFLICTS = "openmoko-theme-standard"
+RPROVIDES = "openmoko-theme-standard-2"
+PV = "0.1.0+${SVNREV}"
+PR = "r0"
+
+inherit openmoko2
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/OM-2007.2/artwork/themes;module=openmoko-standard-2-qvga;proto=http"
+S = "${WORKDIR}/openmoko-standard-2-qvga"
+
+do_install() {
+ find ${WORKDIR} -name ".svn" | xargs rm -rf
+ install -d ${D}${datadir}/themes/openmoko-standard-2/gtk-2.0
+ cp -fpPR ${S}/* ${D}${datadir}/themes/openmoko-standard-2/
+ rm -rf ${D}${datadir}/themes/openmoko-standard-2/patches/
+
+ install -d ${D}${sysconfdir}/gtk-2.0
+ echo 'include "${datadir}/themes/openmoko-standard-2/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
+}
+
+CONFFILES_${PN} = "${sysconfdir}/gtk-2.0/gtkrc"
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = "${datadir} ${sysconfdir}"