summaryrefslogtreecommitdiff
path: root/packages/openmoko-tools/serial-forward.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-03-17 16:00:48 +0000
committerHolger Freyther <zecke@selfish.org>2008-03-17 16:00:48 +0000
commit9a4113fa26927867f33b35579de32f72b0728218 (patch)
treea80e32d15314c9def6cc5e18a57b1026d7f4fa9a /packages/openmoko-tools/serial-forward.bb
parent8f3ab9deabfec95eae9d7a19b1ad974e98a0b710 (diff)
Add my tools to forward the Serial from the Neo to my PC and provide a PTY on the PC
Diffstat (limited to 'packages/openmoko-tools/serial-forward.bb')
-rw-r--r--packages/openmoko-tools/serial-forward.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/openmoko-tools/serial-forward.bb b/packages/openmoko-tools/serial-forward.bb
new file mode 100644
index 0000000000..3cc33770d6
--- /dev/null
+++ b/packages/openmoko-tools/serial-forward.bb
@@ -0,0 +1,15 @@
+LICENSE="GPL"
+SUMMARY="Forward a serial using TCP/IP"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S="${WORKDIR}/serial_forward"
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/forward ${D}/${bindir}/${PN}
+}