summaryrefslogtreecommitdiff
path: root/packages/openmoko-spaces
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-01-17 09:03:38 +0000
committerOpenmoko anonymizer key <devel@lists.openmoko.org>2008-01-17 09:03:38 +0000
commit357ee099c60ddf4fe162b8e24aeeba52edf4099a (patch)
treee129dbc695257cf5ccce54cdd6316cb2f428df43 /packages/openmoko-spaces
parent048ace2a52af79397c783867a0fe2a37d671baf4 (diff)
(Merge OM mtn modification back into mainline)
Integrate mainstream to build meta-toolchain-openmoko packages/meta/meta-toolchain-openmoko.bb: will install task-openmoko-toolchain-{target,host} task-openmoko-toolchain-target: specific to target arch. task-openmoko-toolchain-host: for host and all, such as openmoko-sample2-src moko-autorev.inc, sane-srcrevs.inc: add SRCREV_pn-openmoko-toolchain-scripts openmoko-toolchain-scripts_svn.bb: will not install sample code now. openmoko-sample2_svn.bb: update PACKAGE_ARCH_${PN}-src to be used by ipkg-sdk.conf
Diffstat (limited to 'packages/openmoko-spaces')
-rw-r--r--packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb b/packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb
index 1526cbab55..7533f81958 100644
--- a/packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb
+++ b/packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb
@@ -1,15 +1,14 @@
DESCRIPTION = "Convenient scripts to be used with openmoko toolchain."
-PACKAGE_ARCH = "all"
+PR = "r1"
SRC_URI = "svn://svn.openmoko.org/developers/john_lee;module=toolkit;proto=http"
-SRC_URI += "svn://svn.openmoko.org/trunk/src/target/OM-2007.2/applications;module=openmoko-sample2;proto=http"
-SRCREV="3630"
+S = "${WORKDIR}/toolkit"
+
FILES_${PN} = "/"
do_install () {
- (find ${WORKDIR} -type d -name ".svn" | xargs rm -rf) || true
- install -m 755 -d ${D}/share
- cp -dr ${WORKDIR}/toolkit/* ${D}
- cp -dr ${WORKDIR}/openmoko-sample2 ${D}/share
+ cp -dr ${S}/* ${D}
+ find ${D} -name ".svn" | xargs rm -rf
+ rm -r ${D}/patches
}