summaryrefslogtreecommitdiff
path: root/packages/openmoko-projects
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-03-19 09:33:56 +0000
committerKoen Kooi <koen@openembedded.org>2008-03-19 09:33:56 +0000
commite61d3468b0560cf56577d6899235b10babf750ae (patch)
treea6f29125d8f62ccee0197c361212ab2e8e0b728a /packages/openmoko-projects
parent9c758d97899a75e7bb172b307d5152f1ca4d2fb3 (diff)
illume: add untested recipe that isn't likely to work (this one does need RDEPENDS)
Diffstat (limited to 'packages/openmoko-projects')
-rw-r--r--packages/openmoko-projects/illume_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/openmoko-projects/illume_svn.bb b/packages/openmoko-projects/illume_svn.bb
new file mode 100644
index 0000000000..b4a1fd9469
--- /dev/null
+++ b/packages/openmoko-projects/illume_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+
+DEPENDS = "e eet evas ecore edje embryo efreet edbus edje-native embryo-native"
+
+PV = "0.0+svn${SRCREV}"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=${PN};proto=https"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR} \
+ --enable-simple-x11 \
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+ find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
+}
+
+FILES_${PN} = "${libdir}/enlightenment/modules/*/*.edj \
+ ${libdir}/enlightenment/modules/*/*.desktop \
+ ${libdir}/enlightenment/modules/*/*/*"
+
+FILES_${PN}-dbg += "${libdir}/enlightenment/modules/*/*/.debug/"