summaryrefslogtreecommitdiff
path: root/packages/openmoko-projects/tichy_git.bb
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-12-01 18:01:09 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-12-01 18:01:09 +0100
commit42c5793dced31d7f0e30dcd93745b024bb81099c (patch)
tree55eab55719ca6eb0590a560451a4c9155762f6af /packages/openmoko-projects/tichy_git.bb
parent7561550296a46418f866833c0b49203f7fd2cd85 (diff)
tichy: This project moved from svn to git, catch up
- Move the SRC_URI to get, increase the PV after the change - Build the latest git version.
Diffstat (limited to 'packages/openmoko-projects/tichy_git.bb')
-rw-r--r--packages/openmoko-projects/tichy_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/openmoko-projects/tichy_git.bb b/packages/openmoko-projects/tichy_git.bb
new file mode 100644
index 0000000000..4a1ffb500e
--- /dev/null
+++ b/packages/openmoko-projects/tichy_git.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python applets manager"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS += "python-pygame virtual/libsdl libsdl-image python-dbus python-pygobject"
+PV = "0.2+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.openmoko.org/git/tichy.git;protocol=git"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}"
+RDEPENDS_${PN} += "python-pygame"
+# This is because pkg-config --libs --cflags sdl doesn't return the correct path (bug in libsdl recipe ?)
+CFLAGS += -I${STAGING_INCDIR}/SDL