summaryrefslogtreecommitdiff
path: root/packages/openmoko-projects/illume-theme_svn.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-05-09 14:23:03 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-05-09 14:23:03 +0000
commit2ea905d370dcfc9c2b4b7f2787cce58de531006e (patch)
treed8411d06d995522e28aa474d880efcfe13379b66 /packages/openmoko-projects/illume-theme_svn.bb
parentb308cdc3283673906ff273f82fcc7409557bcad3 (diff)
illume-theme_svn.bb, illume/keyboard.patch : illume fixes and theme from OM mtn
Diffstat (limited to 'packages/openmoko-projects/illume-theme_svn.bb')
-rw-r--r--packages/openmoko-projects/illume-theme_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/openmoko-projects/illume-theme_svn.bb b/packages/openmoko-projects/illume-theme_svn.bb
new file mode 100644
index 0000000000..b360d3b14a
--- /dev/null
+++ b/packages/openmoko-projects/illume-theme_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+
+PACKAGE_ARCH="all"
+PV = "0.0+svnr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=illume;proto=https"
+S = "${WORKDIR}/illume"
+
+python do_unpack_append() {
+ bb.note("Unpacking to %s" % os.getcwd())
+ os.system("cd illume; tar -xz --no-same-owner -f misc-data/untar-me-from-root.tar.gz")
+}
+
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/config/
+
+ # Make illume the default profile
+ echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+
+ install -m 0644 ${S}/misc-data/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ cp -pPR ${S}/.e/e/config/default ${D}${datadir}/enlightenment/data/config/illume
+}