summaryrefslogtreecommitdiff
path: root/packages/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
commit12f8a39939c28003a39b84713d9a51305511650d (patch)
tree2235c3d2a30eac66c0319b7cff55928990c89bbd /packages/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb
parent058132b8be45ac2041a574782b8800c1956e44d3 (diff)
parentfcbe107913b10643d1ba8ac137de273e12e8854a (diff)
merge of '470ca3fe64c9411d3a7d992db39d5efbed869839'
and '912f388483a3e1703ca89d7b2309723fd3407420'
Diffstat (limited to 'packages/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb')
-rw-r--r--packages/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb b/packages/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb
new file mode 100644
index 0000000000..71a9f3cdb6
--- /dev/null
+++ b/packages/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb
@@ -0,0 +1,33 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2008
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php
+# for a copy of the license)
+#
+# Filename: openmoko-gps_svn.bb
+# Date: 20080101 (YMD)
+
+DESCRIPTION = "A tiny GPS output parser for the Openmoko platform."
+HOMEPAGE = "http://forge.bearstech.com/trac/wiki/OpenmokoGPS"
+SECTION = "base"
+LICENSE = "GPL"
+
+RDEPENDS = "python-pygtk"
+
+PR = "r0"
+
+######################################################################################
+
+SRC_URI = "svn://forge.bearstech.com/bearforge/openmoko;module=gps;rev=9"
+
+S = "${WORKDIR}/gps"
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -d ${D}/usr/share/applications/
+ install -d ${D}/usr/share/pixmaps/
+
+ install -m 0755 ${S}/gps_reader.py ${D}/usr/bin
+ install -m 0644 ${S}/openmoko-gps.desktop ${D}/usr/share/applications/
+ install -m 0644 ${S}/*.png ${D}/usr/share/pixmaps/
+}