summaryrefslogtreecommitdiff
path: root/packages/openal/openal_0.0.8.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-09-23 00:38:29 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-09-23 00:38:29 +0000
commitefa3492c6eaa112592e4d835310cf6d18a849eae (patch)
tree576432fcac54aaa5a49102e1229d979ddf2c0ee9 /packages/openal/openal_0.0.8.bb
parent1c259e381f897d199abc66f6237aeb8542779468 (diff)
parente08f51149bd655e670114418f1f873d93d938fd2 (diff)
merge of '68c1dba00e182241b1e887487fb3c8271f9c0d01'
and '954ad99909199c0ef7c0d21819dce8c20cf40c64'
Diffstat (limited to 'packages/openal/openal_0.0.8.bb')
-rw-r--r--packages/openal/openal_0.0.8.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/openal/openal_0.0.8.bb b/packages/openal/openal_0.0.8.bb
new file mode 100644
index 0000000000..280c5d75e8
--- /dev/null
+++ b/packages/openal/openal_0.0.8.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "OpenAL is a cross-platform 3D audio API."
+DEPENDS = "alsa-lib virtual/libsdl libvorbis"
+
+SRC_URI = "http://www.openal.org/openal_webstf/downloads/${PN}-${PV}.tar.gz \
+ file://void-workaround.patch"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-alsa --enable-sdl --enable-vorbis --disable-mp3 \
+ --disable-smpeg --disable-arts"
+
+do_configure_append () {
+ sed -i "s/@requirements@/alsa vorbis/" admin/pkgconfig/openal.pc
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libopenal"
+
+FILES_libopenal += "${libdir}/libopenal.so.*"
+FILES_openal-dev += "${bindir}/openal-config"
+FILES_openal = ""