summaryrefslogtreecommitdiff
path: root/packages/ode
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-20 14:03:24 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-20 14:03:24 +0000
commitaae6903d9cec3d3cfaf9ce9506a325cbdeed6a9a (patch)
tree3d39bbc0634f3feea4d1689263b0b7d403aba113 /packages/ode
parent3f8fa1d18aee05690f6636a4df6e831e99103d8d (diff)
ode / python-pyode: move to nonworking, needs a lot of gcc4 fixes to compile again
Diffstat (limited to 'packages/ode')
-rw-r--r--packages/ode/.mtn2git_empty0
-rw-r--r--packages/ode/files/.mtn2git_empty0
-rw-r--r--packages/ode/files/config.h48
-rw-r--r--packages/ode/ode_0.5.bb27
4 files changed, 0 insertions, 75 deletions
diff --git a/packages/ode/.mtn2git_empty b/packages/ode/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ode/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ode/files/.mtn2git_empty b/packages/ode/files/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ode/files/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ode/files/config.h b/packages/ode/files/config.h
deleted file mode 100644
index 8711bd91b2..0000000000
--- a/packages/ode/files/config.h
+++ /dev/null
@@ -1,48 +0,0 @@
-/* per-machine configuration. this file is automatically generated. */
-
-#ifndef _ODE_CONFIG_H_
-#define _ODE_CONFIG_H_
-
-/* standard system headers */
-#include <stdio.h>
-#include <stdlib.h>
-#include <math.h>
-#include <string.h>
-#include <stdarg.h>
-#include <malloc.h>
-#include <alloca.h>
-#include <values.h>
-#include <float.h>
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-/* is this a pentium on a gcc-based platform? */
-#undef PENTIUM
-
-/* integer types (we assume int >= 32 bits) */
-typedef char int8;
-typedef unsigned char uint8;
-typedef short int16;
-typedef unsigned short uint16;
-typedef int int32;
-typedef unsigned int uint32;
-
-/* an integer type that we can safely cast a pointer to and
- * from without loss of bits.
- */
-typedef unsigned int intP;
-
-/* select the base floating point type */
-#define dDOUBLE 1
-
-/* the floating point infinity */
-#define dInfinity DBL_MAX
-
-/* available functions */
-
-#ifdef __cplusplus
-}
-#endif
-#endif
diff --git a/packages/ode/ode_0.5.bb b/packages/ode/ode_0.5.bb
deleted file mode 100644
index 3b287d4b36..0000000000
--- a/packages/ode/ode_0.5.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "ODE is an Open Source Physics Engine."
-SECTION = "libs"
-PR = "r0"
-LICENSE = "LGPL"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-${PV}.tgz \
- file://config.h"
-
-do_configure() {
- touch configurator.exe
- chmod a+rx configurator.exe
- install -m 0644 ${WORKDIR}/config.h include/ode/
-}
-
-do_compile() {
- oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" RANLIB="${RANLIB}" AR="${AR} qf " ode-lib
-}
-
-do_stage() {
- install -d ${STAGING_INCDIR}/ode/
- install -m 0644 include/ode/*.h ${STAGING_INCDIR}/ode/
- oe_libinstall -C lib -a libode ${STAGING_LIBDIR}
-}
-
-do_install() {
- :
-}