summaryrefslogtreecommitdiff
path: root/packages/obsolete/libsdl/libsdl-qpe_1.2.7.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-01-14 19:49:17 +0000
committerKoen Kooi <koen@openembedded.org>2007-01-14 19:49:17 +0000
commit09a309304ed0ca5fda7c2e7df5b48536812c8e2d (patch)
tree6a703fc3ccd5cf2725fa0b10b779c8867d020d74 /packages/obsolete/libsdl/libsdl-qpe_1.2.7.bb
parentc841192bd7b5665bce645a62e8172669de74a016 (diff)
libsql-qpe: move it to packages/obsolete.
The main reason for this is the thread on the mailinglist, the secondary reason is the the opie people decided to b0rk their patches so they don't apply anymore.
Diffstat (limited to 'packages/obsolete/libsdl/libsdl-qpe_1.2.7.bb')
-rw-r--r--packages/obsolete/libsdl/libsdl-qpe_1.2.7.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/packages/obsolete/libsdl/libsdl-qpe_1.2.7.bb b/packages/obsolete/libsdl/libsdl-qpe_1.2.7.bb
new file mode 100644
index 0000000000..60c2a9d385
--- /dev/null
+++ b/packages/obsolete/libsdl/libsdl-qpe_1.2.7.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "Simple DirectMedia Layer - QtE-based Palmtop Environments Edition"
+SECTION = "opie/libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libqpe1 libopie2"
+PROVIDES = "virtual/libsdl"
+LICENSE = "LGPL"
+
+# NOTE: make sure to keep PR in sync with libsdl-x11
+PR = "r9"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+ file://agawa-piro-mickey.patch;patch=1 \
+ file://pygame.patch;patch=1 \
+ file://gcc34.patch;patch=1 \
+ file://mouse.patch;patch=1 \
+ file://kill-stdc++.patch;patch=1 \
+ file://ipaq.patch;patch=1 \
+ file://SDL-Akita.patch;patch=1 \
+ file://fixlibs.patch;patch=1"
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
+ --enable-file --enable-oss --disable-alsa --disable-esd --disable-arts \
+ --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
+ --disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
+ --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
+ --disable-video-xbios --disable-video-gem --disable-video-dummy \
+ --disable-video-opengl --enable-input-events --enable-pthreads \
+ --disable-video-picogui --enable-video-qtopia --enable-dlopen"
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/*config"
+
+do_compile_prepend() {
+ if [ "${PALMTOP_USE_MULTITHREADED_QT}" == "yes" ]
+ then
+ sed -i s,-lqte,-lqte-mt, src/Makefile
+ fi
+}
+
+do_stage() {
+ oe_libinstall -so -C src libSDL ${STAGING_LIBDIR}
+ rm ${STAGING_LIBDIR}/libSDL.la
+ ln -sf libSDL.so ${STAGING_LIBDIR}/libSDL-1.2.so
+ install -m 0655 src/main/libSDLmain.a src/main/.libs/
+ oe_libinstall -a -C src/main libSDLmain ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/SDL
+ for f in include/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/SDL/
+ done
+
+ install -m 0644 *.m4 ${STAGING_DATADIR}/aclocal/
+}