summaryrefslogtreecommitdiff
path: root/packages/nxcl/libnxcl_0.9.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-09-06 12:03:30 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-09-06 12:03:30 +0000
commitb5004b8d1433cb8fe5cdbe94b7aae378b56f7c44 (patch)
tree9fd1391ceb3346d48bfe4eaa2d7ad42d3a4c52ff /packages/nxcl/libnxcl_0.9.bb
parent2c6f4b857c2742fc7aae63fa78ebe81d044439e8 (diff)
libnxcl: import nxcl to openembedded
* libnxcl is the backend library for the opensource nx-clients * gcc4.3-ftbfs.patch taken from the debian unstable package * disabled nxcmd, bescause it is useles * disabled doxygen-doku too * third step for nx-client support in oe
Diffstat (limited to 'packages/nxcl/libnxcl_0.9.bb')
-rw-r--r--packages/nxcl/libnxcl_0.9.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/nxcl/libnxcl_0.9.bb b/packages/nxcl/libnxcl_0.9.bb
new file mode 100644
index 0000000000..ea62579019
--- /dev/null
+++ b/packages/nxcl/libnxcl_0.9.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Backend library for the free nx-clients"
+HOMEPAGE = "http://freenx.berlios.de/"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r0"
+
+RDEPENDS = "nxproxy ssh"
+
+SRC_URI = "http://download.berlios.de/freenx/freenx-client-${PV}.tar.bz2 \
+ file://gcc4.3-ftbfs.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/freenx-client-${PV}/nxcl"
+
+EXTRA_OECONF += "--without-nxcmd \
+ --without-doxygen \
+ "
+
+inherit lib_package autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}