summaryrefslogtreecommitdiff
path: root/packages/nunome
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-06-12 14:45:27 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-06-12 14:45:27 +0000
commitb1f4d34f8541f039d72d423223c91e32540a2fc5 (patch)
treec50f34a595a58cb31a25d96727c3e2c9c27c0a91 /packages/nunome
parent10013e9ed4e79a2f6ca0ceb6451787aaa47c46e5 (diff)
parentb655c71aac44af6eab2a52774ea810a945592cee (diff)
merge of '30c320b2f51c86226580e5bbf68fa8b0896a0655'
and '8dfee9b2427785432e4161eb7cc749155230e08e'
Diffstat (limited to 'packages/nunome')
-rw-r--r--packages/nunome/files/timer.patch21
-rw-r--r--packages/nunome/nunome_1.0.2.bb4
2 files changed, 24 insertions, 1 deletions
diff --git a/packages/nunome/files/timer.patch b/packages/nunome/files/timer.patch
new file mode 100644
index 0000000000..ccd65647be
--- /dev/null
+++ b/packages/nunome/files/timer.patch
@@ -0,0 +1,21 @@
+diff --git a/ui/nnmCanvas.cpp b/ui/nnmCanvas.cpp
+index a548ddf..3b8e7d4 100755
+--- a/ui/nnmCanvas.cpp
++++ b/ui/nnmCanvas.cpp
+@@ -35,7 +35,7 @@
+
+ nnmCanvas::nnmCanvas( QWidget *parent, int timeoutParam, int initID,
+ const char *name, WFlags f )
+- : QWidget( parent, name, f )
++ : QWidget( parent, name, f ), timer(0)
+ {
+ setFixedSize( NnmCANVAS_DISPLAY_SIZE, NnmCANVAS_DISPLAY_SIZE );
+ init();
+@@ -149,7 +149,7 @@ void nnmCanvas::resizeEvent( QResizeEvent *event )
+
+ void nnmCanvas::init( void )
+ {
+- if ( timeoutMsec > 0 && timer->isActive() ) {
++ if ( timeoutMsec > 0 && timer && timer->isActive() ) {
+ timer->stop();
+ } \ No newline at end of file
diff --git a/packages/nunome/nunome_1.0.2.bb b/packages/nunome/nunome_1.0.2.bb
index ae29277291..0401c195e0 100644
--- a/packages/nunome/nunome_1.0.2.bb
+++ b/packages/nunome/nunome_1.0.2.bb
@@ -1,11 +1,13 @@
DESCRIPTION = "Japanese input method plugin"
+HOMEPAGE = "http://www.sikigami.com/nunome-Qtopia-1.0/"
SECTION = "opie/inputmethods"
PRIORITY = "optional"
LICENSE = "GPL"
-HOMEPAGE = "http://www.sikigami.com/nunome-Qtopia-1.0/"
RDEPENDS = "virtual/japanese-font"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/nunome-${PV}.tar.bz2 \
+ file://timer.patch;patch=1 \
file://nunome.patch;patch=1"
S = "${WORKDIR}/nunome"