summaryrefslogtreecommitdiff
path: root/packages/ntp
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-07-08 05:56:05 +0000
committerRod Whitby <rod@whitby.id.au>2007-07-08 05:56:05 +0000
commit598873b16965f4fa24bdde2de2d39aef52ae1283 (patch)
tree4b1963fb7c3db7a1d4a4ce29915de96608207c4b /packages/ntp
parent154af708451cce6148f55a8942c03d29d90c7fc7 (diff)
parent6fc2762e3570cab046062795247010363d5460d6 (diff)
merge of '5076ed26abde44cf0e9a27bb249bb0829b19ea16'
and 'ecca9e62d3b19e42cb09d54766c2633bb3023046'
Diffstat (limited to 'packages/ntp')
-rw-r--r--packages/ntp/ntp-4.2.2p3/tickadj.c.patch32
-rw-r--r--packages/ntp/ntp_4.2.2p3.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/packages/ntp/ntp-4.2.2p3/tickadj.c.patch b/packages/ntp/ntp-4.2.2p3/tickadj.c.patch
new file mode 100644
index 0000000000..9ef9de9e1f
--- /dev/null
+++ b/packages/ntp/ntp-4.2.2p3/tickadj.c.patch
@@ -0,0 +1,32 @@
+Index: ntp-4.2.2p3-r0/ntp-4.2.2p3/util/tickadj.c
+===================================================================
+--- ntp-4.2.2p3/util/tickadj.c 2004-02-25 06:58:33.000000000 +0100
++++ ntp-4.2.2p3/util/tickadj.c 2007-07-07 01:00:54.000000000 +0200
+@@ -21,7 +21,8 @@
+ # include <unistd.h>
+ #endif /* HAVE_UNISTD_H */
+
+-#ifdef HAVE___ADJTIMEX /* Linux */
++/* proper handling here has been moved to upstream ntp bugzilla */
++#ifdef linux
+
+ #include <sys/timex.h>
+ struct timex txc;
+@@ -91,7 +92,7 @@
+ }
+
+ if (!errflg) {
+- if (__adjtimex(&txc) < 0)
++ if (adjtimex(&txc) < 0)
+ perror("adjtimex");
+ else if (!quiet)
+ printf("tick = %ld\ntick_adj = %d\n",
+@@ -146,7 +147,7 @@
+ #endif
+ }
+
+- if (__adjtimex(&txc) < 0)
++ if (adjtimex(&txc) < 0)
+ {
+ perror("adjtimex");
+ }
diff --git a/packages/ntp/ntp_4.2.2p3.bb b/packages/ntp/ntp_4.2.2p3.bb
index 28853e4fc8..ad861cf8f5 100644
--- a/packages/ntp/ntp_4.2.2p3.bb
+++ b/packages/ntp/ntp_4.2.2p3.bb
@@ -2,6 +2,7 @@ require ntp.inc
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/${P}.tar.gz \
file://ipv6only-workaround.patch;patch=1 \
+ file://tickadj.c.patch;patch=1 \
file://ntpd \
file://ntp.conf \
file://ntpdate"