summaryrefslogtreecommitdiff
path: root/packages/nonworking/zethereal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nonworking/zethereal
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nonworking/zethereal')
-rw-r--r--packages/nonworking/zethereal/.mtn2git_empty0
-rw-r--r--packages/nonworking/zethereal/zethereal_1.0.0.bb54
2 files changed, 54 insertions, 0 deletions
diff --git a/packages/nonworking/zethereal/.mtn2git_empty b/packages/nonworking/zethereal/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/zethereal/.mtn2git_empty
diff --git a/packages/nonworking/zethereal/zethereal_1.0.0.bb b/packages/nonworking/zethereal/zethereal_1.0.0.bb
index e69de29bb2..54b60a5d4a 100644
--- a/packages/nonworking/zethereal/zethereal_1.0.0.bb
+++ b/packages/nonworking/zethereal/zethereal_1.0.0.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "The network packet dissector Ethereal, Qt/Embedded based Palmtop Environments Edition"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "glib-1.2 openssl"
+MAINTAINER = "Michael 'Mickey' Lauer"
+HOMEPAGE = "http://www.cartel-info.fr/pbiondi/zaurus/"
+APPNAME = "zethereal"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+PR = "r0"
+
+inherit autotools qmake-base
+
+EXTRA_OECONF = "--disable-ethereal \
+ --enable-tethereal \
+ --disable-editcap \
+ --disable-mergecap \
+ --disable-text2pcap \
+ --disable-idl2eth \
+ --without-ucdsnmp \
+ --disable-usr-local \
+ --with-pcap=${STAGING_LIBDIR}/.. \
+ --with-zlib=${STAGING_LIBDIR}/.. \
+ --without-x"
+
+export GLIB_CONFIG = "${STAGING_BINDIR}/glib-config"
+
+CFLAGS += "-I${STAGING_INCDIR}/glib-1.2"
+LIBS += "-lglib-1.2"
+
+SRC_URI = "http://www.cartel-info.fr/pbiondi/zaurus/ethereal-0.9.5.tar.gz \
+ http://www.cartel-info.fr/pbiondi/zaurus/zethereal-1.0.tar.gz"
+S = "${WORKDIR}/ethereal-0.9.5"
+
+do_compile() {
+ oe_runmake SUBDIRS="wiretap"
+ mv ${WORKDIR}/qtopia .
+ ${AR} r libzethereal.a packet-*.o afn.o asn1.o column.o conditions.o \
+ capture_stop_conditions.o follow.o in_cksum.o ipproto.o pcap-u \
+ til.o prefs.o print.o ps.o ptvcursor.o reassemble.o ringbuffer.o \
+ util.o xdlc.o xmlstub.o register.o
+ cd qtopia
+ qmake -spec ${QMAKESPEC} zethereal.pro && oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+