summaryrefslogtreecommitdiff
path: root/packages/nonworking/xlibs
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nonworking/xlibs
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nonworking/xlibs')
-rw-r--r--packages/nonworking/xlibs/.mtn2git_empty0
-rw-r--r--packages/nonworking/xlibs/xext_6.4.3.bb17
-rw-r--r--packages/nonworking/xlibs/xmu_6.2.3.bb13
3 files changed, 30 insertions, 0 deletions
diff --git a/packages/nonworking/xlibs/.mtn2git_empty b/packages/nonworking/xlibs/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/xlibs/.mtn2git_empty
diff --git a/packages/nonworking/xlibs/xext_6.4.3.bb b/packages/nonworking/xlibs/xext_6.4.3.bb
index e69de29bb2..f8a17fe2db 100644
--- a/packages/nonworking/xlibs/xext_6.4.3.bb
+++ b/packages/nonworking/xlibs/xext_6.4.3.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "X Server Extension library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "xproto x11 xextensions"
+
+SRC_URI = "${XLIBS_MIRROR}/libXext-${PV}.tar.bz2"
+S = "${WORKDIR}/libXext-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}
diff --git a/packages/nonworking/xlibs/xmu_6.2.3.bb b/packages/nonworking/xlibs/xmu_6.2.3.bb
index e69de29bb2..cad9bdc5d5 100644
--- a/packages/nonworking/xlibs/xmu_6.2.3.bb
+++ b/packages/nonworking/xlibs/xmu_6.2.3.bb
@@ -0,0 +1,13 @@
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "xt xext xaw"
+
+SRC_URI = "${XLIBS_MIRROR}/libXmu-${PV}.tar.bz2"
+S = "${WORKDIR}/libXmu-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_runmake install DESTDIR="" bindir=${STAGING_BINDIR} includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} prefix=${STAGING_DIR}
+}