summaryrefslogtreecommitdiff
path: root/packages/nonworking/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nonworking/python
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nonworking/python')
-rw-r--r--packages/nonworking/python/.mtn2git_empty0
-rw-r--r--packages/nonworking/python/python-gsl-0.2.0/.mtn2git_empty0
-rw-r--r--packages/nonworking/python/python-gsl-0.2.0/cross-compile.patch18
-rw-r--r--packages/nonworking/python/python-gsl_0.2.0.bb15
-rw-r--r--packages/nonworking/python/python-pycap_0.1.6.bb12
-rw-r--r--packages/nonworking/python/python-pyx_0.6.bb14
6 files changed, 59 insertions, 0 deletions
diff --git a/packages/nonworking/python/.mtn2git_empty b/packages/nonworking/python/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/python/.mtn2git_empty
diff --git a/packages/nonworking/python/python-gsl-0.2.0/.mtn2git_empty b/packages/nonworking/python/python-gsl-0.2.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/python/python-gsl-0.2.0/.mtn2git_empty
diff --git a/packages/nonworking/python/python-gsl-0.2.0/cross-compile.patch b/packages/nonworking/python/python-gsl-0.2.0/cross-compile.patch
index e69de29bb2..69f68c7dc0 100644
--- a/packages/nonworking/python/python-gsl-0.2.0/cross-compile.patch
+++ b/packages/nonworking/python/python-gsl-0.2.0/cross-compile.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- pygsl-0.2.0/gsl_Extension.py~cross-compile 2003-11-19 10:08:53.000000000 +0100
++++ pygsl-0.2.0/gsl_Extension.py 2004-02-16 16:32:15.000000000 +0100
+@@ -85,8 +85,8 @@
+ else:
+ self.gsl_config_tool="gsl-config"
+
+- self.prefix = self.get_gsl_info('--prefix').strip()
+- self.cflags = self.get_gsl_info('--cflags').strip()
++ self.prefix = os.getenv( "STAGING" )+"/target"
++ self.cflags = self.get_gsl_info('--cflags').strip() + " -I%s/python2.3/include" % os.getenv( "STAGING" )
+ self.libs = self.get_gsl_info('--libs').strip()
+ self.version = self._split_version(self.get_gsl_info('--version').strip())
+
diff --git a/packages/nonworking/python/python-gsl_0.2.0.bb b/packages/nonworking/python/python-gsl_0.2.0.bb
index e69de29bb2..4a504cc15e 100644
--- a/packages/nonworking/python/python-gsl_0.2.0.bb
+++ b/packages/nonworking/python/python-gsl_0.2.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION=GNU Scientific Library Python Bindings
+SECTION=base
+PRIORITY=optional
+MAINTAINER="Michael Lauer <mickey@Vanille.de>"
+RDEPENDS=python-core gsl
+DEPENDS=gsl
+SRCNAME=pygsl
+
+SRC_URI = ${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://${FILESDIR}/cross-compile.patch;patch=1
+S = ${WORKDIR}/${SRCNAME}-${PV}
+
+inherit distutils
+
+export STAGING=${STAGING_DIR}
diff --git a/packages/nonworking/python/python-pycap_0.1.6.bb b/packages/nonworking/python/python-pycap_0.1.6.bb
index e69de29bb2..2bcf37a594 100644
--- a/packages/nonworking/python/python-pycap_0.1.6.bb
+++ b/packages/nonworking/python/python-pycap_0.1.6.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Python Packet Capture Library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael Lauer <mickey@Vanille.de>"
+RDEPENDS = "python-core"
+DEPENDS = "libpcap-0.7.2 libnet-1.1.1"
+SRCNAME = "pycap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
diff --git a/packages/nonworking/python/python-pyx_0.6.bb b/packages/nonworking/python/python-pyx_0.6.bb
index e69de29bb2..8bdaedfc67 100644
--- a/packages/nonworking/python/python-pyx_0.6.bb
+++ b/packages/nonworking/python/python-pyx_0.6.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "PyX is a Python package for the creation of encapsulated PostScript figures. \
+It provides both an abstraction of PostScript and a TeX/LaTeX interface. Complex tasks like \
+2d and 3d plots in publication-ready quality are built out of these primitives."
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+RDEPENDS = "python-core"
+DEPENDS = "kpsewhich-native"
+SRCNAME = "PyX"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pyx/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils