summaryrefslogtreecommitdiff
path: root/packages/nonworking/lzma
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/nonworking/lzma
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/nonworking/lzma')
-rw-r--r--packages/nonworking/lzma/.mtn2git_empty0
-rw-r--r--packages/nonworking/lzma/lzma_0.01.bb33
2 files changed, 33 insertions, 0 deletions
diff --git a/packages/nonworking/lzma/.mtn2git_empty b/packages/nonworking/lzma/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/lzma/.mtn2git_empty
diff --git a/packages/nonworking/lzma/lzma_0.01.bb b/packages/nonworking/lzma/lzma_0.01.bb
index e69de29bb2..2530dc4211 100644
--- a/packages/nonworking/lzma/lzma_0.01.bb
+++ b/packages/nonworking/lzma/lzma_0.01.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "LZMA is a compression algorithm, based on the famous \
+Lempel Ziff compression method. The windows only open source tool 7-zip \
+is another tool which uses this algorithm."
+SECTION = "libs"
+PRIORITY = "optional"
+
+SRC_URI = "http://students.fhs-hagenberg.ac.at/se/se00001/lzma-0.01.tar.bz2"
+S = "${WORKDIR}/"
+
+inherit qmake
+
+do_configure_prepend() {
+ ${STAGING_BINDIR}/qmake -project -o lzma.pro
+}
+
+do_install_append () {
+ # Make install doesn't properly install these
+ oe_libinstall -so -C shlib libhistory ${D}/${libdir}
+ oe_libinstall -so -C shlib libreadline ${D}/${libdir}
+}
+
+do_stage() {
+ oe_libinstall -so -C shlib libhistory ${STAGING_LIBDIR}
+ oe_libinstall -so -C shlib libreadline ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/readline
+ for f in readline.h chardefs.h keymaps.h history.h tilde.h rlstdc.h \
+ rlconf.h rltypedefs.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/readline/
+ done
+
+}