summaryrefslogtreecommitdiff
path: root/packages/nonworking/clucene
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2007-05-20 12:27:51 +0000
committerRichard Purdie <rpurdie@rpsys.net>2007-05-20 12:27:51 +0000
commitbb7af3e7c1d87e66755ffdbe08801418a3a56c14 (patch)
tree351cf7dc436a2eb0f180fbea8a201417528c6390 /packages/nonworking/clucene
parent9375e3001c13e0ebe5290a024dc7c61d6696d4f6 (diff)
clucene: Move to nonworking. its cvs doesn't exist any more
Diffstat (limited to 'packages/nonworking/clucene')
-rw-r--r--packages/nonworking/clucene/.mtn2git_empty0
-rw-r--r--packages/nonworking/clucene/clucene-0.8.12-pre/.mtn2git_empty0
-rw-r--r--packages/nonworking/clucene/clucene-0.8.12-pre/compile-fix.patch23
-rw-r--r--packages/nonworking/clucene/clucene_0.8.12-pre.bb24
4 files changed, 47 insertions, 0 deletions
diff --git a/packages/nonworking/clucene/.mtn2git_empty b/packages/nonworking/clucene/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/clucene/.mtn2git_empty
diff --git a/packages/nonworking/clucene/clucene-0.8.12-pre/.mtn2git_empty b/packages/nonworking/clucene/clucene-0.8.12-pre/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/clucene/clucene-0.8.12-pre/.mtn2git_empty
diff --git a/packages/nonworking/clucene/clucene-0.8.12-pre/compile-fix.patch b/packages/nonworking/clucene/clucene-0.8.12-pre/compile-fix.patch
new file mode 100644
index 0000000000..5f6c8f1911
--- /dev/null
+++ b/packages/nonworking/clucene/clucene-0.8.12-pre/compile-fix.patch
@@ -0,0 +1,23 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- clucene-0.8.11-r0/src/CLucene/store/Lock.cpp~compile-fix 2004-04-13 15:43:21.000000000 +0200
++++ clucene-0.8.11-r0/src/CLucene/store/Lock.cpp 2004-07-08 00:21:06.000000000 +0200
+@@ -1,6 +1,6 @@
+ #include "CLucene/StdHeader.h"
+ #include "Lock.h"
+-
++using namespace std;
+ namespace lucene{ namespace store{
+
+ LuceneLockWith::~LuceneLockWith(){
+--- clucene-0.8.11-r0/Makefile.am~compile-fix 2003-11-04 07:54:04.000000000 +0100
++++ clucene-0.8.11-r0/Makefile.am 2004-07-08 00:22:43.000000000 +0200
+@@ -2,4 +2,4 @@
+
+ INCLUDES = -I$(top_srcdir)
+
+-SUBDIRS = src wrappers examples .
++SUBDIRS = src wrappers .
diff --git a/packages/nonworking/clucene/clucene_0.8.12-pre.bb b/packages/nonworking/clucene/clucene_0.8.12-pre.bb
new file mode 100644
index 0000000000..2c8122c921
--- /dev/null
+++ b/packages/nonworking/clucene/clucene_0.8.12-pre.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "CLucene is a C++ port of Lucene: the high-performance, full-featured text search engine written in Java."
+SECTION = "libs"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SRCDATE = "20040704"
+SRC_URI = "cvs://anonymous@clucene.cvs.sourceforge.net/cvsroot/clucene;module=. \
+ file://compile-fix.patch;patch=1"
+S = "${WORKDIR}"
+
+inherit autotools
+
+do_stage() {
+ oe_libinstall -C src libclucene ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/CLucene/
+ install src/CLucene.h ${STAGING_INCDIR}/CLucene/
+ cd src
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -d ${STAGING_INCDIR}/`dirname $f`
+ install -m 0644 $f ${STAGING_INCDIR}/$f
+ done
+ echo > ${STAGING_INCDIR}/CLucene/util/dirent.h
+}