summaryrefslogtreecommitdiff
path: root/packages/nonworking/centericq/centericq-4.11.0/configure.patch
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-05-06 00:41:48 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-05-06 00:41:48 +0000
commit5c3a71d6bd2a212d89f2f5c7a7c08d16fa3b7511 (patch)
treec51069f41baca16fc7dcc0609a53828ea8853c37 /packages/nonworking/centericq/centericq-4.11.0/configure.patch
parentd8261fbae1d661e49f8a0b83e0b3ea481a2f42ea (diff)
parent4037c4a087635e50671fee29182cde8e93708bd6 (diff)
merge of '5c57f792fa4408bfd1d31632734168b1434d7100'
and 'de01edf0c06eb0cc6e3c6b19195f32bc67519b19'
Diffstat (limited to 'packages/nonworking/centericq/centericq-4.11.0/configure.patch')
-rw-r--r--packages/nonworking/centericq/centericq-4.11.0/configure.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/packages/nonworking/centericq/centericq-4.11.0/configure.patch b/packages/nonworking/centericq/centericq-4.11.0/configure.patch
new file mode 100644
index 0000000000..aea7a493f8
--- /dev/null
+++ b/packages/nonworking/centericq/centericq-4.11.0/configure.patch
@@ -0,0 +1,66 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- centericq-4.11.0/./configure.in~configure
++++ centericq-4.11.0/./configure.in
+@@ -85,12 +85,12 @@
+ AC_MSG_RESULT([not found or disabled])
+ with_ssl="no"
+
+- AM_PATH_LIBGNUTLS_EXTRA(0.0.1, [
+- CXXFLAGS="$CXXFLAGS $LIBGNUTLS_CFLAGS"
+- LIBS="$LIBS $LIBGNUTLS_LIBS -lgnutls-extra"
+- AC_DEFINE(HAVE_GNUTLS, 1, [use gnutls])
+- with_ssl="yes"
+- ])
++# AM_PATH_LIBGNUTLS_EXTRA(0.0.1, [
++# CXXFLAGS="$CXXFLAGS $LIBGNUTLS_CFLAGS"
++# LIBS="$LIBS $LIBGNUTLS_LIBS -lgnutls-extra"
++# AC_DEFINE(HAVE_GNUTLS, 1, [use gnutls])
++# with_ssl="yes"
++# ])
+ fi
+ fi
+
+--- centericq-4.11.0/./connwrap-0.1/configure.in~configure
++++ centericq-4.11.0/./connwrap-0.1/configure.in
+@@ -45,29 +45,29 @@
+ else
+ AC_MSG_RESULT([not found or disabled])
+
+- AM_PATH_LIBGNUTLS_EXTRA(0.0.1, [
+- CXXFLAGS="$CXXFLAGS $LIBGNUTLS_CFLAGS"
+- LIBS="$LIBS $LIBGNUTLS_LIBS -lgnutls-extra"
+- AC_DEFINE(HAVE_GNUTLS)
+- ])
++# AM_PATH_LIBGNUTLS_EXTRA(0.0.1, [
++# CXXFLAGS="$CXXFLAGS $LIBGNUTLS_CFLAGS"
++# LIBS="$LIBS $LIBGNUTLS_LIBS -lgnutls-extra"
++# AC_DEFINE(HAVE_GNUTLS)
++# ])
+ fi
+ fi
+
+ AC_MSG_CHECKING(for inet_aton() presence)
+
+-AC_TRY_LINK([
++AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+-], [
++]], [[
+
+ struct in_addr inp;
+ inet_aton("address", &inp);
+
+-], have_aton=yes, have_aton=no)
++]])],[have_aton=yes],[have_aton=no])
+
+ if test "$have_aton" = "yes"; then
+ AC_DEFINE(HAVE_INET_ATON)