summaryrefslogtreecommitdiff
path: root/packages/nis
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/nis
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/nis')
-rw-r--r--packages/nis/files/libdl.patch12
-rw-r--r--packages/nis/files/no-selinux.patch16
-rw-r--r--packages/nis/nis-all.bb13
-rw-r--r--packages/nis/nis.inc34
-rw-r--r--packages/nis/pwdutils_2.6.bb41
-rw-r--r--packages/nis/yp-tools_2.9.bb11
-rw-r--r--packages/nis/ypbind-mt_1.18.bb23
-rw-r--r--packages/nis/ypbind-mt_1.19.bb21
-rw-r--r--packages/nis/ypserv_2.17.bb14
9 files changed, 0 insertions, 185 deletions
diff --git a/packages/nis/files/libdl.patch b/packages/nis/files/libdl.patch
deleted file mode 100644
index 605af319f9..0000000000
--- a/packages/nis/files/libdl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- pwdutils-2.6/configure.in.orig 2005-04-19 20:22:36.603052192 -0700
-+++ pwdutils-2.6/configure.in 2005-04-19 21:09:45.308023672 -0700
-@@ -178,6 +178,9 @@
- AC_CHECK_LIB(ldap, main, LDAP_LIBS="-lldap $LDAP_LIBS" found_ldap_lib=yes,,$LDAP_LIBS)
- fi
-
-+ dnl this always needs dl
-+ AC_CHECK_LIB(dl, dlopen, LDAP_LIBS="$LDAP_LIBS -ldl")
-+
- if test -z "$found_ldap_lib" -a \( $with_ldap_lib = auto -o $with_ldap_lib = netscape5 \); then
- AC_CHECK_LIB(ldap50, main, LDAP_LIBS="-lldap50 -lssldap50 -lssl3 -lnss3 -lnspr4 -lprldap50 -lplc4 -lplds4" found_ldap_lib=yes need_pthread=true,, -lpthread)
- fi
diff --git a/packages/nis/files/no-selinux.patch b/packages/nis/files/no-selinux.patch
deleted file mode 100644
index 71da3e3931..0000000000
--- a/packages/nis/files/no-selinux.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- pwdutils-2.6/lib/copy_xattr.c.orig 2005-04-16 17:15:52.916660880 -0700
-+++ pwdutils-2.6/lib/copy_xattr.c 2005-04-16 17:18:10.345768480 -0700
-@@ -127,8 +127,11 @@
-
- if (lsetxattr (to, name, value, size, 0) != 0)
- {
-- if (strcmp (name, "security.selinux") == 0 &&
-- is_selinux_enabled() == 0)
-+ if (strcmp (name, "security.selinux") == 0
-+#if defined(WITH_SELINUX)
-+ && is_selinux_enabled() == 0
-+#endif
-+ )
- fprintf (stderr,
- _("SELinux not enabled, ignore attribute %s for `%s'.\n"),
- name, to);
diff --git a/packages/nis/nis-all.bb b/packages/nis/nis-all.bb
deleted file mode 100644
index 181a06cd2e..0000000000
--- a/packages/nis/nis-all.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-# This meta package is a convenience to build all of the
-# NIS packages.
-#
-
-DESCRIPTION="NIS services"
-HOMEPAGE="http://www.linux-nis.org/nis/"
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "GPLv2"
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-DEPENDS = "yp-tools ypbind ypserv pwdutils"
diff --git a/packages/nis/nis.inc b/packages/nis/nis.inc
deleted file mode 100644
index 90f7ff50a0..0000000000
--- a/packages/nis/nis.inc
+++ /dev/null
@@ -1,34 +0,0 @@
-# This include file contains global definitions for the
-# various NIS packages.
-#
-# These packages will only function correctly with glibc -
-# the rpcsvc functionality is not present in uclibc
-DESCRIPTION ?= "NIS Server and Tools"
-HOMEPAGE ?= "http://www.linux-nis.org/nis/"
-SECTION ?= "console/network"
-PRIORITY ?= "optional"
-LICENSE ?= "GPLv2"
-
-# Override these *after* the include file if necessary!
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/net/NIS/${P}.tar.bz2"
-
-inherit autotools gettext
-
-# install is broken because src/Makefile heroically adds '-s'
-# to the install flags - passing -s to the build /usr/bin/install!
-# install-strip gets it right but installs ypbind -m <default>,
-# not -m 555. In an OE build this is not, so far as I can see,
-# a security problem (and this fix to the build problem is *much*
-# easier and more maintainable.)
-do_install() {
- oe_runmake 'DESTDIR=${D}' install-strip
-}
-
-# An attempt to build on uclibc will fail, causing annoyance,
-# so force the package to be skipped here (this will cause a
-# 'nothing provides' error)
-python () {
- os = bb.data.getVar("TARGET_OS", d, 1)
- if os == "linux-uclibc":
- raise bb.parse.SkipPackage("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
-}
diff --git a/packages/nis/pwdutils_2.6.bb b/packages/nis/pwdutils_2.6.bb
deleted file mode 100644
index 0e01e7e104..0000000000
--- a/packages/nis/pwdutils_2.6.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-# This package builds tools to manage NIS passwords
-# The source package is utils/net/NIS/pwdutils
-# The package requires -lpam
-#
-PR = "r1"
-DESCRIPTION="\
-NIS PAM password management tools. \
-This is a collection of utilities to manage the passwd \
-information stored in local files, NIS, NIS+ or LDAP \
-and can replace the shadow suite completely."
-HOMEPAGE="http://lists.suse.com/archive/pwdutils/"
-
-require nis.inc
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/net/NIS/OLD/${PN}/${P}.tar.bz2"
-
-# an selinux API is used even if no selinux is detected by
-# configure.
-SRC_URI += " file://no-selinux.patch;patch=1"
-SRC_URI += " file://libdl.patch;patch=1"
-
-DEPENDS += " libpam openldap openssl"
-
-# -Werror is set within the pwdutils configure.in!
-# You might prefer to use -Wno-error rather than the
-# following long list.
-#
-# #if undefined happens in bits/string2.h and probably
-# elsewhere (since it is a standard safe C programming
-# practice - safer than #ifdef!)
-TARGET_CFLAGS += " -Wno-undef"
-# bits/socket.h has a macro which casts 'up' (increasing
-# the alignment requirement) but it is in a macro which
-# does the alignment correctly, so the following warning
-# needs to be non-error'ed. I just turn it off...
-TARGET_CFLAGS += " -Wno-cast-align"
-# openssl contains large numbers of declarations wherein
-# f() is used instead of f(void), so:
-TARGET_CFLAGS += " -Wno-strict-prototypes"
-# openssl uses error as a local variable, so:
-TARGET_CFLAGS += " -Wno-shadow"
diff --git a/packages/nis/yp-tools_2.9.bb b/packages/nis/yp-tools_2.9.bb
deleted file mode 100644
index ddf7ed2c8d..0000000000
--- a/packages/nis/yp-tools_2.9.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-# This package builds tools to manage NIS
-# The source package is utils/net/NIS/yp-tools
-#
-PR = "r0"
-DESCRIPTION="\
-Network Information Service tools. \
-This package contains ypcat, ypmatch, ypset, \
-ypwhich, yppasswd, domainname, nisdomainname \
-and ypdomainname."
-
-require nis.inc
diff --git a/packages/nis/ypbind-mt_1.18.bb b/packages/nis/ypbind-mt_1.18.bb
deleted file mode 100644
index be37fb9c28..0000000000
--- a/packages/nis/ypbind-mt_1.18.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-# This package builds the NIS ypbind daemon
-# The source package is utils/net/NIS/ypbind-mt
-#
-PR = "r0"
-DESCRIPTION="\
-Multithreaded NIS bind service (ypbind-mt). \
-ypbind-mt is a complete new implementation of a NIS \
-binding daemon for Linux. It has the following \
-features. Supports ypbind protocol V1 and V2. \
-Uses threads for better response. Supports multiple \
-domain bindings. Supports /var/yp/binding/* file \
-for Linux libc 4/5 and glibc 2.x. Supports a list \
-of known secure NIS server (/etc/yp.conf) Binds to \
-the server which answered as first."
-HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
-
-require nis.inc
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/net/NIS/OLD/${PN}/${P}.tar.bz2"
-
-# ypbind-mt now provides all the functionality of ypbind
-# and is used in place of it.
-PROVIDES += "ypbind"
diff --git a/packages/nis/ypbind-mt_1.19.bb b/packages/nis/ypbind-mt_1.19.bb
deleted file mode 100644
index aee0864937..0000000000
--- a/packages/nis/ypbind-mt_1.19.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-# This package builds the NIS ypbind daemon
-# The source package is utils/net/NIS/ypbind-mt
-#
-PR = "r0"
-DESCRIPTION="\
-Multithreaded NIS bind service (ypbind-mt). \
-ypbind-mt is a complete new implementation of a NIS \
-binding daemon for Linux. It has the following \
-features. Supports ypbind protocol V1 and V2. \
-Uses threads for better response. Supports multiple \
-domain bindings. Supports /var/yp/binding/* file \
-for Linux libc 4/5 and glibc 2.x. Supports a list \
-of known secure NIS server (/etc/yp.conf) Binds to \
-the server which answered as first."
-HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
-
-require nis.inc
-
-# ypbind-mt now provides all the functionality of ypbind
-# and is used in place of it.
-PROVIDES += "ypbind"
diff --git a/packages/nis/ypserv_2.17.bb b/packages/nis/ypserv_2.17.bb
deleted file mode 100644
index 07d8aee5bb..0000000000
--- a/packages/nis/ypserv_2.17.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-# This package builds the NIS server
-# The source package is utils/net/NIS/ypserv
-#
-PR = "r0"
-DESCRIPTION="NIS version 2 server for Linux."
-HOMEPAGE="http://www.linux-nis.org/nis/ypserv/index.html"
-
-require nis.inc
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/net/NIS/OLD/${PN}/${P}.tar.bz2"
-
-# ypserv needs a database package, gdbm is currently the
-# only candidate
-DEPENDS += " gdbm"