summaryrefslogtreecommitdiff
path: root/packages/netbase
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2009-02-13 14:12:54 -0500
committerPhilip Balister <philip@balister.org>2009-02-13 14:12:54 -0500
commit18992093169e9ebd2a61989b853986a77199be35 (patch)
treed08928e78b95ea9dcbd7a4f5a193b18e197e8a8d /packages/netbase
parent36001a65d7eb5f4432b999d24c29501834a3b431 (diff)
parent97b340db7c7b9ee3ed53e02eaa63c9873f4e1610 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/netbase')
-rw-r--r--packages/netbase/netbase/om-gta01/interfaces2
-rw-r--r--packages/netbase/netbase/om-gta02/interfaces2
-rw-r--r--packages/netbase/netbase/ronetix-pm9261/interfaces72
-rw-r--r--packages/netbase/netbase/ronetix-pm9263/interfaces72
-rw-r--r--packages/netbase/netbase_4.21.bb2
5 files changed, 147 insertions, 3 deletions
diff --git a/packages/netbase/netbase/om-gta01/interfaces b/packages/netbase/netbase/om-gta01/interfaces
index df85b1e854..56c485ef75 100644
--- a/packages/netbase/netbase/om-gta01/interfaces
+++ b/packages/netbase/netbase/om-gta01/interfaces
@@ -16,7 +16,7 @@ iface eth1 inet dhcp
# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
-auto usb0
+allow-hotplug usb0
iface usb0 inet static
address 192.168.0.202
netmask 255.255.255.0
diff --git a/packages/netbase/netbase/om-gta02/interfaces b/packages/netbase/netbase/om-gta02/interfaces
index 6caf915794..ceedfc59c2 100644
--- a/packages/netbase/netbase/om-gta02/interfaces
+++ b/packages/netbase/netbase/om-gta02/interfaces
@@ -16,7 +16,7 @@ iface eth1 inet dhcp
# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
-auto usb0
+allow-hotplug usb0
iface usb0 inet static
address 192.168.0.202
netmask 255.255.255.0
diff --git a/packages/netbase/netbase/ronetix-pm9261/interfaces b/packages/netbase/netbase/ronetix-pm9261/interfaces
new file mode 100644
index 0000000000..ab20f5b37b
--- /dev/null
+++ b/packages/netbase/netbase/ronetix-pm9261/interfaces
@@ -0,0 +1,72 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+
+# Wireless interfaces
+#
+# Example of an unencrypted (no WEP or WPA) wireless connection
+# that connects to any available access point:
+#
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+#
+#
+# Same as above but locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless_mode managed
+# wireless-essid some-essid
+#
+# A WEP encrypted connection locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless-essid some-essid
+# wireless-key s:My-PlainText-Password
+# wireless-mode managed
+#
+# A WPA1 or WPA2 encrypted connection locked to a specific access point.
+# This is the best option for non-roaming, single-network usage.
+# Note that your card may require a firmware update to use WPA.
+# Some distributions install a temporary volatile firmware update on ifup.
+#
+#iface wlan0 inet dhcp
+# wpa-essid some-essid
+# wpa-psk My-PlainText-Password
+#
+# A WPA1 or WPA2 encrypted connection using an external configuration file
+# for wpa-supplicant. This is the way to go if you need to configure multiple
+# networks with different keys and / or WPA settings and roaming support.
+#
+# iface wlan0 inet dhcp
+# wpa-conf /etc/wpa_supplicant.conf
+# wpa-driver hostap
+
+
+
+iface atml0 inet dhcp
+
+# Wired or wireless interfaces
+auto eth0
+iface eth0 inet static
+ address 192.168.0.184
+ netmask 255.255.255.0
+ network 192.168.0.0
+ gateway 192.168.0.1
+
+iface eth1 inet dhcp
+
+# Ethernet/RNDIS gadget (g_ether)
+# ... or on host side, usbnet and random hwaddr
+iface usb0 inet static
+ address 192.168.0.202
+ netmask 255.255.255.0
+ network 192.168.0.0
+ gateway 192.168.0.200
+
+# Bluetooth networking
+iface bnep0 inet dhcp
+
diff --git a/packages/netbase/netbase/ronetix-pm9263/interfaces b/packages/netbase/netbase/ronetix-pm9263/interfaces
new file mode 100644
index 0000000000..ab20f5b37b
--- /dev/null
+++ b/packages/netbase/netbase/ronetix-pm9263/interfaces
@@ -0,0 +1,72 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+
+# Wireless interfaces
+#
+# Example of an unencrypted (no WEP or WPA) wireless connection
+# that connects to any available access point:
+#
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+#
+#
+# Same as above but locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless_mode managed
+# wireless-essid some-essid
+#
+# A WEP encrypted connection locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless-essid some-essid
+# wireless-key s:My-PlainText-Password
+# wireless-mode managed
+#
+# A WPA1 or WPA2 encrypted connection locked to a specific access point.
+# This is the best option for non-roaming, single-network usage.
+# Note that your card may require a firmware update to use WPA.
+# Some distributions install a temporary volatile firmware update on ifup.
+#
+#iface wlan0 inet dhcp
+# wpa-essid some-essid
+# wpa-psk My-PlainText-Password
+#
+# A WPA1 or WPA2 encrypted connection using an external configuration file
+# for wpa-supplicant. This is the way to go if you need to configure multiple
+# networks with different keys and / or WPA settings and roaming support.
+#
+# iface wlan0 inet dhcp
+# wpa-conf /etc/wpa_supplicant.conf
+# wpa-driver hostap
+
+
+
+iface atml0 inet dhcp
+
+# Wired or wireless interfaces
+auto eth0
+iface eth0 inet static
+ address 192.168.0.184
+ netmask 255.255.255.0
+ network 192.168.0.0
+ gateway 192.168.0.1
+
+iface eth1 inet dhcp
+
+# Ethernet/RNDIS gadget (g_ether)
+# ... or on host side, usbnet and random hwaddr
+iface usb0 inet static
+ address 192.168.0.202
+ netmask 255.255.255.0
+ network 192.168.0.0
+ gateway 192.168.0.200
+
+# Bluetooth networking
+iface bnep0 inet dhcp
+
diff --git a/packages/netbase/netbase_4.21.bb b/packages/netbase/netbase_4.21.bb
index 9d5f2c6826..fd0fb6dac2 100644
--- a/packages/netbase/netbase_4.21.bb
+++ b/packages/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPL"
-PR = "r30"
+PR = "r31"
inherit update-rc.d