summaryrefslogtreecommitdiff
path: root/packages/neon
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-10 22:24:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-10 22:24:53 +0000
commit81089c05a2dde5b035426bbcac4865fdca34a209 (patch)
treed4f752e789d3aaac95a5b232d21f9fcff2353447 /packages/neon
parent05537392106bfa338801b7ec0af451601ace917e (diff)
parent97ea9e42c5a7213362eaee90b02c722503ccecae (diff)
merge of 03b24ac5bbfd34988917e742c3d058a0e65c9cae
and 89b41334d0c4e264e8d1a5cc4598404379f62dfd
Diffstat (limited to 'packages/neon')
-rw-r--r--packages/neon/neon_0.24.7.bb18
1 files changed, 12 insertions, 6 deletions
diff --git a/packages/neon/neon_0.24.7.bb b/packages/neon/neon_0.24.7.bb
index 2e2ba4de59..d53260b3cf 100644
--- a/packages/neon/neon_0.24.7.bb
+++ b/packages/neon/neon_0.24.7.bb
@@ -1,18 +1,24 @@
-inherit autotools
-
-DEPENDS = "zlib libxml2 expat"
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
SECTION = "base"
LICENSE = "LGPL"
-DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+DEPENDS = "openssl zlib libxml2 expat time"
+
PR = "r1"
SRC_URI = "http://www.webdav.org/neon/neon-0.24.7.tar.gz \
file://no-func-checks.patch;patch=1"
-EXTRA_OECONF = " --without-ssl --with-libxml2 --with-expat \
- --enable-shared --enable-static"
+inherit autotools lib_package
+
+EXTRA_OECONF = " --with-ssl --with-libxml2 --with-expat --enable-shared"
do_stage () {
autotools_stage_includes
oe_libinstall -C src -so -a libneon ${STAGING_LIBDIR}/
+
+ cat neon-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/neon-config
+ chmod a+rx ${STAGING_BINDIR}/neon-config
}