summaryrefslogtreecommitdiff
path: root/packages/mythtv/mythtv_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-22 10:42:25 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-22 10:42:25 +0000
commit97356e8a1c274a2886622226e15937cf110c86f8 (patch)
treeba6d041e5bb30feff34610bb814f466a246de226 /packages/mythtv/mythtv_svn.bb
parent48e1aea67481a039f2dbd282937e4549d3d63497 (diff)
mythtv: the configure does link tests first (which succeed) and then goes to check if the lib exists in LDPATH. This is bogus, so rig the path check.
Diffstat (limited to 'packages/mythtv/mythtv_svn.bb')
-rw-r--r--packages/mythtv/mythtv_svn.bb20
1 files changed, 19 insertions, 1 deletions
diff --git a/packages/mythtv/mythtv_svn.bb b/packages/mythtv/mythtv_svn.bb
index 2d7d7ac938..303462e69f 100644
--- a/packages/mythtv/mythtv_svn.bb
+++ b/packages/mythtv/mythtv_svn.bb
@@ -43,6 +43,22 @@ python __anonymous () {
bb.data.setVar("PACKAGES", packages, d)
}
+
+EXTRA_OECONF_armv5te = " --enable-armv5te "
+EXTRA_OECONF_armv6 = " --enable-armv6 "
+EXTRA_OECONF_armv7a = --enable-armv6"
+
+#build with support for the iwmmxt instruction and pxa270fb overlay support (pxa270 and up)
+#not every iwmmxt machine has the lcd connected to pxafb, but building the module doesn't hurt
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '${MY_ARCH}',d)}"
+
+MY_TARGET_CC_ARCH := "${TARGET_CC_ARCH}"
+TARGET_CC_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
+
+EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable-pxa --enable-iwmmxt', '',d)} "
+
+
do_configure_prepend() {
# it's not autotools anyway, so we call ./configure directly
find . -name "Makefile"|xargs rm -f
@@ -50,13 +66,15 @@ do_configure_prepend() {
--mandir=/usr/man \
--cpu=${MYTHTV_ARCH} \
--disable-altivec \
+ --disable-strip \
--enable-v4l \
--enable-audio-oss \
--enable-proc-opt \
--enable-dvb \
--enable-libmp3lame \
--cross-compile \
- --dvb-path=${STAGING_INCDIR}
+ --dvb-path=${STAGING_INCDIR} \
+ ${EXTRA_OECONF}
sed 's!PREFIX =.*!PREFIX = ${prefix}!;/INCLUDEPATH += $${PREFIX}\/include/d' < settings.pro > settings.pro.new
mv settings.pro.new settings.pro