summaryrefslogtreecommitdiff
path: root/packages/mysql
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-10 14:51:54 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-10 14:51:54 +0000
commit491515fb2f411eed26eaa22cc08cc36843f75190 (patch)
treeb6e1cd2463c65f61400c4040615802ea6cbe4485 /packages/mysql
parent3d742bb070f089d28aff59fd0a7c66d62d6a4432 (diff)
mysql: use autotools_stage_all to get libs into libdir/mysql as they should. The old wrong behaviour is left alone to minimize breakage
Diffstat (limited to 'packages/mysql')
-rw-r--r--packages/mysql/mysql_4.1.18.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/mysql/mysql_4.1.18.bb b/packages/mysql/mysql_4.1.18.bb
index cd32f929e3..2017463c36 100644
--- a/packages/mysql/mysql_4.1.18.bb
+++ b/packages/mysql/mysql_4.1.18.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.mysql.com/"
SECTION = "libs"
LICENSE = "GPL"
DEPENDS += "ncurses mysql-native"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://downloads.mysql.com/archives/mysql-4.1/mysql-${PV}.tar.gz \
file://autofoo.patch;patch=1 \
@@ -28,7 +28,7 @@ EXTRA_OEMAKE = "'GEN_LEX_HASH=${STAGING_BINDIR_NATIVE}/gen_lex_hash'"
EXTRA_OECONF = " --with-embedded-server --prefix=/usr --sysconfdir=/etc/mysql --localstatedir=/var/mysql --datadir=/var/mysql --disable-dependency-tracking --without-raid --without-debug --with-low-memory --without-query-cache --without-man --without-docs --without-innodb "
do_stage() {
- autotools_stage_includes
+ autotools_stage_all
oe_libinstall -a -so -C libmysql libmysqlclient ${STAGING_LIBDIR}
oe_libinstall -a -C libmysqld libmysqld ${STAGING_LIBDIR}
}