summaryrefslogtreecommitdiff
path: root/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/mysql/mysql-4.1.10a/gen_lex_hash.patch
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/mysql/mysql-4.1.10a/gen_lex_hash.patch')
-rw-r--r--packages/mysql/mysql-4.1.10a/gen_lex_hash.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch b/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch
index e69de29bb2..27bfc0f6a3 100644
--- a/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch
+++ b/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch
@@ -0,0 +1,21 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mysql-4.1.4a-gamma/sql/Makefile.am~gen_lex_hash
++++ mysql-4.1.4a-gamma/sql/Makefile.am
+@@ -140,9 +140,10 @@
+ @echo "If it fails, re-run configure with --with-low-memory"
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
+-lex_hash.h: lex.h gen_lex_hash.cc sql_yacc.h
+- $(MAKE) gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
++lex_hash.h: lex.h gen_lex_hash$(EXEEXT) sql_yacc.h
++ $(GEN_LEX_HASH) > $@ || rm -f $@
+
+ # Hack to ensure that lex_hash.h is built early
+ sql_lex.o: lex_hash.h