summaryrefslogtreecommitdiff
path: root/packages/mutt/mutt-1.5.9i/sidebar-nntp-clash.patch
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-08-04 15:50:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-04 15:50:38 +0000
commit304c18632bf0ecf124285b737bb4cc8d2b0f561d (patch)
tree75f962c29cb4dfe5098bb88ba1c93ef423472cea /packages/mutt/mutt-1.5.9i/sidebar-nntp-clash.patch
parentf5460842ff42fa992fd8b299be96e725b4de888a (diff)
parent484899fc65e7fddf14760b0e53e921f39f5a7cb4 (diff)
merge of 2819ed65548adb15c53612a3b51eb7bef109c647
and 87f058a530faa6a89df3767295e8e2a5faaa073e
Diffstat (limited to 'packages/mutt/mutt-1.5.9i/sidebar-nntp-clash.patch')
-rw-r--r--packages/mutt/mutt-1.5.9i/sidebar-nntp-clash.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/packages/mutt/mutt-1.5.9i/sidebar-nntp-clash.patch b/packages/mutt/mutt-1.5.9i/sidebar-nntp-clash.patch
new file mode 100644
index 0000000000..c180f1861f
--- /dev/null
+++ b/packages/mutt/mutt-1.5.9i/sidebar-nntp-clash.patch
@@ -0,0 +1,63 @@
+--- mutt-1.5.9/compose.c.orig 2005-08-04 10:58:39.282202360 +0000
++++ mutt-1.5.9/compose.c 2005-08-04 11:02:58.420807304 +0000
+@@ -146,16 +146,16 @@
+ if ((WithCrypto & APPLICATION_PGP) && (WithCrypto & APPLICATION_SMIME))
+ {
+ if (!msg->security)
+- mvaddstr (HDR_CRYPT, 0, " Security: ");
++ mvaddstr (HDR_CRYPT, SidebarWidth, " Security: ");
+ else if (msg->security & APPLICATION_SMIME)
+- mvaddstr (HDR_CRYPT, 0, " S/MIME: ");
++ mvaddstr (HDR_CRYPT, SidebarWidth, " S/MIME: ");
+ else if (msg->security & APPLICATION_PGP)
+- mvaddstr (HDR_CRYPT, 0, " PGP: ");
++ mvaddstr (HDR_CRYPT, SidebarWidth, " PGP: ");
+ }
+ else if ((WithCrypto & APPLICATION_SMIME))
+- mvaddstr (HDR_CRYPT, 0, " S/MIME: ");
++ mvaddstr (HDR_CRYPT, SidebarWidth, " S/MIME: ");
+ else if ((WithCrypto & APPLICATION_PGP))
+- mvaddstr (HDR_CRYPT, 0, " PGP: ");
++ mvaddstr (HDR_CRYPT, SidebarWidth, " PGP: ");
+ else
+ return;
+
+@@ -294,21 +294,21 @@
+ }
+ else
+ {
+- mvprintw (HDR_TO, 0, TITLE_FMT , Prompts[HDR_NEWSGROUPS - 1]);
++ mvprintw (HDR_TO, SidebarWidth, TITLE_FMT , Prompts[HDR_NEWSGROUPS - 1]);
+ mutt_paddstr (W, NONULL (msg->env->newsgroups));
+- mvprintw (HDR_CC, 0, TITLE_FMT , Prompts[HDR_FOLLOWUPTO - 1]);
++ mvprintw (HDR_CC, SidebarWidth, TITLE_FMT , Prompts[HDR_FOLLOWUPTO - 1]);
+ mutt_paddstr (W, NONULL (msg->env->followup_to));
+ if (option (OPTXCOMMENTTO))
+ {
+- mvprintw (HDR_BCC, 0, TITLE_FMT , Prompts[HDR_XCOMMENTTO - 1]);
++ mvprintw (HDR_BCC, SidebarWidth, TITLE_FMT , Prompts[HDR_XCOMMENTTO - 1]);
+ mutt_paddstr (W, NONULL (msg->env->x_comment_to));
+ }
+ }
+ #endif
+- mvprintw (HDR_SUBJECT, 0, TITLE_FMT, Prompts[HDR_SUBJECT - 1]);
++ mvprintw (HDR_SUBJECT, SidebarWidth, TITLE_FMT, Prompts[HDR_SUBJECT - 1]);
+ mutt_paddstr (W, NONULL (msg->env->subject));
+ draw_envelope_addr (HDR_REPLYTO, msg->env->reply_to);
+- mvprintw (HDR_FCC, 0, TITLE_FMT, Prompts[HDR_FCC - 1]);
++ mvprintw (HDR_FCC, SidebarWidth, TITLE_FMT, Prompts[HDR_FCC - 1]);
+ mutt_paddstr (W, fcc);
+
+ if (WithCrypto)
+--- mutt-1.5.9/Makefile.am.orig 2005-08-04 11:22:12.390377264 +0000
++++ mutt-1.5.9/Makefile.am 2005-08-04 11:22:29.806729576 +0000
+@@ -28,7 +28,8 @@
+ score.c send.c sendlib.c signal.c sort.c \
+ status.c system.c thread.c charset.c history.c lib.c \
+ muttlib.c editmsg.c utf8.c mbyte.c wcwidth.c \
+- url.c ascii.c mutt_idna.c crypt-mod.c crypt-mod.h
++ url.c ascii.c mutt_idna.c crypt-mod.c crypt-mod.h \
++ sidebar.c
+
+ mutt_LDADD = @MUTT_LIB_OBJECTS@ @LIBOBJS@ $(LIBIMAP) $(MUTTLIBS) \
+ $(INTLLIBS) $(LIBICONV) $(LIBGPGME_LIBS)