summaryrefslogtreecommitdiff
path: root/packages/mtools/files/m486.patch
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-01-22 10:20:29 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-01-22 18:51:24 -0200
commitb5cd58e9ecc3c80e54222368e3c704a0b25d6e90 (patch)
treefbcbd511350b57d28c8d6cd2e1aae08bf81f7739 /packages/mtools/files/m486.patch
parentd8e12feec852f733e4d1d67c3de3b7dc8deec282 (diff)
mtools: fix 3.9.11 recipe to properly compile
Compilation was failing due a wrong command line param being passed to GCC. This patch fixes it. ,----[ Failure ] | cc1: error: unrecognized command line option "-m486" `---- Besides the compilation error, mtools.patch is not necessary anymore and not applicable to this version, thus droped.
Diffstat (limited to 'packages/mtools/files/m486.patch')
-rw-r--r--packages/mtools/files/m486.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/packages/mtools/files/m486.patch b/packages/mtools/files/m486.patch
new file mode 100644
index 0000000000..e6303247bc
--- /dev/null
+++ b/packages/mtools/files/m486.patch
@@ -0,0 +1,48 @@
+#!/bin/sh -e
+## 07-m486.dpatch by Matthias Klose <doko@ubuntu.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: #474817: mtools: FTBFS: cc1: error: unrecognized command line option "-m486"
+
+if [ $# -lt 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
+
+case "$1" in
+ -patch) patch $patch_opts -p1 < $0;;
+ -unpatch) patch $patch_opts -p1 -R < $0;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+--- mtools-3.9.11.orig/configure.in
++++ mtools-3.9.11/configure.in
+@@ -249,7 +249,7 @@
+ objs=`echo $srcdir/*.c | sed 's/\.c$/.o/' `
+ if [ "X$GCC" = "Xyes" ] ; then
+ if [ "$host_cpu" = i486 ] ; then
+- CFLAGS="$CFLAGS -m486"
++ CFLAGS="$CFLAGS"
+ fi
+ Wall=-Wall
+ if [ "$host_os3" = sunos ] ; then
+unchanged:
+--- mtools-3.9.11.orig/configure
++++ mtools-3.9.11/configure
+@@ -5905,7 +5905,7 @@
+ objs=`echo $srcdir/*.c | sed 's/\.c$/.o/' `
+ if [ "X$GCC" = "Xyes" ] ; then
+ if [ "$host_cpu" = i486 ] ; then
+- CFLAGS="$CFLAGS -m486"
++ CFLAGS="$CFLAGS"
+ fi
+ Wall=-Wall
+ if [ "$host_os3" = sunos ] ; then