summaryrefslogtreecommitdiff
path: root/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-02 00:40:06 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-02 00:40:06 +0000
commit2df9cbeb2f6dadb15ae2b35bc6738898441c8bb6 (patch)
tree14041a10f11ffd209e027dbd71139debfc586171 /packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch
parentf84e0ededff77945b6bff613d01e301f4b440041 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/02 00:29:40+00:00 nexus.co.uk!pb remove gweled from gpe-games one more time 2005/01/02 00:27:53+00:00 nexus.co.uk!pb add gpe-soundbite to task-gpe-apps. remove useless miniclipboard. 2005/01/02 00:26:33+00:00 nexus.co.uk!pb patch libsvg to use expat rather than libxml2 2005/01/02 00:22:09+00:00 (none)!cwiiis Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into cwiiisdesktop.(none):/home/cwiiis/oe/openembedded 2005/01/02 00:21:52+00:00 (none)!cwiiis Bump PR on gpe-session-scripts (and a mvdir back and forth, sorry) 2005/01/02 00:18:53+00:00 (none)!cwiiis Merge 2005/01/02 00:08:17+00:00 (none)!cwiiis Add collie key-mappings. 2005/01/02 00:03:14+00:00 (none)!cwiiis Complete move of gpe-task-games to meta-gpe. 2005/01/02 00:50:26+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/01/02 00:50:13+01:00 uni-frankfurt.de!mickeyl upgrade wlan-ng to 0.2.1pre23 and reset PACKAGE_ARCH for the utils packages. this .bb looks pretty suboptimal, splitting it up into a modules and a utils .bb would be useful 2005/01/01 19:23:45+01:00 uni-frankfurt.de!mickeyl s/collie-fl/sharp_fl/ in devices initscript BKrev: 41d742e6y8_hdUO3hSBlG_tQVPYNiw
Diffstat (limited to 'packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch')
-rw-r--r--packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch102
1 files changed, 102 insertions, 0 deletions
diff --git a/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch b/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch
index e69de29bb2..da21b48e72 100644
--- a/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch
+++ b/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch
@@ -0,0 +1,102 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mtd/util/mkfs.jffs2.c~add-exclusion-to-mkfs-jffs2.patch
++++ mtd/util/mkfs.jffs2.c
+@@ -92,7 +92,12 @@
+ struct filesystem_entry *files; /* Only relevant to directories */
+ };
+
++struct ignorepath_entry {
++ struct ignorepath_entry* next; /* Points to the next ignorepath element */
++ char name[PATH_MAX]; /* Name of the entry */
++};
+
++static struct ignorepath_entry* ignorepath = 0;
+ static int out_fd = -1;
+ static int in_fd = -1;
+ static char default_rootdir[] = ".";
+@@ -367,6 +372,7 @@
+ char *hpath, *tpath;
+ struct dirent *dp, **namelist;
+ struct filesystem_entry *entry;
++ struct ignorepath_entry* element = ignorepath;
+
+
+ if (lstat(hostpath, &sb)) {
+@@ -376,6 +382,15 @@
+ entry = add_host_filesystem_entry(targetpath, hostpath,
+ sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
+
++ while ( element ) {
++ if ( strcmp( element->name, hostpath ) == 0 ) {
++ printf( "Note: ignoring directories below '%s'\n", hostpath );
++ return entry;
++ break;
++ }
++ element = element->next;
++ }
++
+ n = scandir(hostpath, &namelist, 0, alphasort);
+ if (n < 0) {
+ perror_msg_and_die("opening directory %s", hostpath);
+@@ -1147,6 +1162,7 @@
+ {"root", 1, NULL, 'r'},
+ {"pagesize", 1, NULL, 's'},
+ {"eraseblock", 1, NULL, 'e'},
++ {"ignore", 1, NULL, 'I'},
+ {"output", 1, NULL, 'o'},
+ {"help", 0, NULL, 'h'},
+ {"verbose", 0, NULL, 'v'},
+@@ -1189,6 +1205,7 @@
+ " -L, --list-compressors Show the list of the avaiable compressors\n"
+ " -t, --test-compression Call decompress and compare with the original (for test)\n"
+ " -n, --no-cleanmarkers Don't add a cleanmarker to every eraseblock\n"
++ " -I, --ignore=PATH Ignore sub directory and file tree below PATH when recursing over the file system\n"
+ " -o, --output=FILE Output to FILE (default: stdout)\n"
+ " -l, --little-endian Create a little-endian filesystem\n"
+ " -b, --big-endian Create a big-endian filesystem\n"
+@@ -1349,11 +1366,12 @@
+ struct filesystem_entry *root;
+ char *compr_name = NULL;
+ int compr_prior = -1;
++ struct ignorepath_entry* element = ignorepath;
+
+ jffs2_compressors_init();
+
+ while ((opt = getopt_long(argc, argv,
+- "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
++ "D:d:r:s:i:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
+ {
+ switch (opt) {
+ case 'D':
+@@ -1376,6 +1394,27 @@
+ page_size = strtol(optarg, NULL, 0);
+ break;
+
++ case 'I':
++ printf( "Note: Adding '%s' to ignore Path\n", optarg );
++ if ( !ignorepath ) {
++ ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
++ ignorepath->next = 0;
++ strcpy( &ignorepath->name[0], optarg );
++ } else {
++ while ( element->next ) element = element->next;
++ element->next = xmalloc( sizeof( struct ignorepath_entry ) );
++ element->next->next = 0;
++ strcpy( &element->next->name[0], optarg );
++ }
++ printf( "--------- Dumping ignore path list ----------------\n" );
++ element=ignorepath;
++ while ( element ) {
++ printf( " * '%s'\n", &element->name[0] );
++ element = element->next;
++ }
++ printf( "---------------------------------------------------\n" );
++ break;
++
+ case 'o':
+ if (out_fd != -1) {
+ error_msg_and_die("output filename specified more than once");