summaryrefslogtreecommitdiff
path: root/packages/mt-daapd/mt-daapd.inc
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-09 18:23:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-09 18:23:50 +0000
commit59e9f82f043c54916fa79f6a0d7de63aeeb655e7 (patch)
tree2da32edfd991bcf7e8538f9e250e5964bd4b4df2 /packages/mt-daapd/mt-daapd.inc
parent4bd012399e50314e009bd3ef1c413b9fb7225823 (diff)
mt-daapd: fix 0.2.1.1 to work with 'iTunes5'
The fix applies a patch copied from www.mt-daapd.org, the patch is copied because the version at the web site has path names (well, no path names) which don't work with OE. This commit also adds a .bb for mt-daapd_0.2.2, but since that hasn't been released it doesn't work (yet) and is DPed out.
Diffstat (limited to 'packages/mt-daapd/mt-daapd.inc')
-rw-r--r--packages/mt-daapd/mt-daapd.inc26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/mt-daapd/mt-daapd.inc b/packages/mt-daapd/mt-daapd.inc
new file mode 100644
index 0000000000..28b0a1e284
--- /dev/null
+++ b/packages/mt-daapd/mt-daapd.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "multi threaded daap server for POSIX Systems: iTunes Server."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
+DEPENDS = "zlib gdbm libid3tag"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz \
+ file://${PN}.init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "${PN}"
+INITSCRIPT_PARAMS = "defaults 84"
+
+EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes"
+
+do_install() {
+ autotools_do_install
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}/contrib/${PN}.conf ${D}${sysconfdir}
+ install -m 0755 ${WORKDIR}/${PN}.init ${D}${sysconfdir}/init.d/${PN}
+}
+
+CONFFILES_${PN} = "${sysconfdir}/${PN}.conf"