summaryrefslogtreecommitdiff
path: root/packages/mplayer/mplayer_svn.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-06-21 10:35:14 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-21 10:35:14 +0000
commit5f36b6daccbf0bcd4eeeea2ee797826612b3f345 (patch)
treef10f3e5805674267b419b6c38d475a3de33ada35 /packages/mplayer/mplayer_svn.bb
parentc42d24b5fa03ee99ee73030dd09e93d6dd1eb14a (diff)
mplayer_svn.bb : new svn build of mplayer
Diffstat (limited to 'packages/mplayer/mplayer_svn.bb')
-rw-r--r--packages/mplayer/mplayer_svn.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/packages/mplayer/mplayer_svn.bb b/packages/mplayer/mplayer_svn.bb
new file mode 100644
index 0000000000..7af431430b
--- /dev/null
+++ b/packages/mplayer/mplayer_svn.bb
@@ -0,0 +1,74 @@
+DESCRIPTION = "Open Source multimedia player."
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.mplayerhq.hu/"
+DEPENDS = "virtual/libsdl libmad zlib libpng jpeg mplayer-common"
+RDEPENDS = "mplayer-common"
+LICENSE = "GPL"
+SRC_URI = "svn://svn.mplayerhq.hu/;module=mplayer \
+ file://vo_w100.c \
+ file://vo_w100_api.h \
+ file://vo_w100_fb.h \
+ file://Makefile.patch;patch=1 \
+ file://w100-configure.patch;patch=1 \
+ file://w100-Makefile.patch;patch=1 \
+ file://w100-video_out.patch;patch=1 \
+ file://w100-mplayer.patch;patch=1"
+
+MAINTAINER="Graeme Gregory <dp@xora.org.uk>"
+RCONFLICTS_${PN} = "mplayer-atty"
+RREPLACES_${PN} = "mplayer-atty"
+
+PV = "1.0pre8+svn${SRCDATE}"
+PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
+PARALLEL_MAKE = ""
+
+DEPENDS_append_c7x0 = " sharp-aticore-oss"
+
+S = "${WORKDIR}/mplayer/trunk/"
+
+PACKAGES =+ "mencoder"
+
+FILES_${PN} = "${bindir}/mplayer"
+FILES_mencoder = "${bindir}/mencoder"
+
+inherit autotools
+
+EXTRA_OECONF = " \
+ --prefix=/usr \
+ --mandir=${mandir} \
+ --target=${TARGET_SYS} \
+ \
+ --enable-mencoder \
+ --disable-gui \
+ --enable-largefiles \
+ --disable-linux-devfs \
+ --disable-lirc \
+ --disable-lircc \
+ --disable-tv \
+ --enable-rtc \
+ --disable-smb \
+ --disable-win32 \
+ \
+ --enable-tremor-low \
+ --disable-mp3lib \
+ \
+ --disable-x11 \
+ --enable-sdl \
+ --enable-fbdev "
+
+EXTRA_OECONF_append_c7x0 = " --enable-w100 "
+
+do_configure() {
+ cp ${WORKDIR}/vo_w100.c ${S}/libvo
+ cp ${WORKDIR}/vo_w100_api.h ${S}/libvo
+ cp ${WORKDIR}/vo_w100_fb.h ${S}/libvo
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake
+}
+