summaryrefslogtreecommitdiff
path: root/packages/mplayer/mplayer_svn.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-10-07 17:18:01 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-10-07 17:18:01 +0000
commitb7a0319b872d44e9ed44be54265da2c6807c4dd6 (patch)
tree1d70829317662d61b6595b89d6b6e614c70277c6 /packages/mplayer/mplayer_svn.bb
parent755eee92d56ca490407fe1fe623d846da44f42ca (diff)
packages/mplayer/mplayer_svn.bb : update the c7x0 and hx4700 w100 support
so they can play with accellerate stuff without having to have x11 installed. Also added check for machine feature x86 to turn on runtime cpu detection so x86 machines with SSE work. Marcin time for you to add it to your favourite toys.
Diffstat (limited to 'packages/mplayer/mplayer_svn.bb')
-rw-r--r--packages/mplayer/mplayer_svn.bb17
1 files changed, 11 insertions, 6 deletions
diff --git a/packages/mplayer/mplayer_svn.bb b/packages/mplayer/mplayer_svn.bb
index bd2bc96b52..4d9c744e79 100644
--- a/packages/mplayer/mplayer_svn.bb
+++ b/packages/mplayer/mplayer_svn.bb
@@ -3,6 +3,9 @@ SECTION = "multimedia"
PRIORITY = "optional"
HOMEPAGE = "http://www.mplayerhq.hu/"
DEPENDS = "virtual/libsdl xsp libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11"
+DEPENDS_append_c7x0 = " libw100 "
+DEPENDS_append_hx4700 = " libw100 "
+
RDEPENDS = "mplayer-common"
LICENSE = "GPL"
SRC_URI = "svn://svn.mplayerhq.hu/mplayer;module=trunk \
@@ -28,14 +31,16 @@ SRC_URI = "svn://svn.mplayerhq.hu/mplayer;module=trunk \
# discovers this is more general than please make this more general
# ie. for all armv4 machines.
SRC_URI_append_collie = "file://disable-executable-stack-test.patch;patch=1"
-PACKAGE_ARCH_mplayer_collie = "collie"
-PACKAGE_ARCH_mencoder_collie = "collie"
+
+PACKAGE_ARCH_collie = "collie"
+PACKAGE_ARCH_c7x0 = "c7x0"
+PACKAGE_ARCH_hx4700 = "hx4700"
RCONFLICTS_${PN} = "mplayer-atty"
RREPLACES_${PN} = "mplayer-atty"
PV = "0.0+1.0rc1+svnr${SRCREV}"
-PR = "r3"
+PR = "r4"
DEFAULT_PREFERENCE = "-1"
PARALLEL_MAKE = ""
@@ -165,13 +170,12 @@ EXTRA_OECONF = " \
--disable-win32waveout \
--enable-select \
\
- --disable-runtime-cpudetection \
"
EXTRA_OECONF_append_arm = " --disable-decoder=vorbis_decoder \
--disable-encoder=vorbis_encoder"
-
-EXTRA_OECONF_append_progear = " --disable-sse --disable-3dnow --disable-mmxext --disable-sse2"
+EXTRA_OECONF_append_c7x0 = " --enable-imageon "
+EXTRA_OECONF_append_hx4700 = " --enable-imageon "
#build with support for the iwmmxt instruction and pxa270fb overlay support (pxa270 and up)
#not every iwmmxt machine has the lcd connected to pxafb, but building the module doesn't hurt
@@ -182,6 +186,7 @@ MY_TARGET_CC_ARCH := "${TARGET_CC_ARCH}"
TARGET_CC_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable-pxa --enable-iwmmxt', '',d)} "
+EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'x86', '--enable-runtime-cpudetection', '',d)} "
do_configure() {
cp ${WORKDIR}/vo_w100.c ${S}/libvo