summaryrefslogtreecommitdiff
path: root/packages/mplayer/mplayer_svn.bb
diff options
context:
space:
mode:
authorGregoire Gentil <gregoire@gentil.com>2008-11-23 22:59:23 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-23 22:59:23 +0100
commit59f5a9c741bba79e6ebf8e6527142aeeb8ea9236 (patch)
treef587ca00c136e4873a7d71c426f0848fa9443fe4 /packages/mplayer/mplayer_svn.bb
parenta989a5ab47bc885c1f3b7436c0ad1b41f42ec8cb (diff)
mplayer svn: add vo_omapfb for the overlay found in omap2/omap3 chips
Diffstat (limited to 'packages/mplayer/mplayer_svn.bb')
-rw-r--r--packages/mplayer/mplayer_svn.bb19
1 files changed, 15 insertions, 4 deletions
diff --git a/packages/mplayer/mplayer_svn.bb b/packages/mplayer/mplayer_svn.bb
index b0f12504d4..4ab8d79054 100644
--- a/packages/mplayer/mplayer_svn.bb
+++ b/packages/mplayer/mplayer_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Open Source multimedia player."
SECTION = "multimedia"
PRIORITY = "optional"
HOMEPAGE = "http://www.mplayerhq.hu/"
-DEPENDS = "virtual/libsdl ffmpeg xsp zlib libpng jpeg freetype fontconfig alsa-lib lzo ncurses libxv virtual/libx11 \
+DEPENDS = "virtual/libsdl ffmpeg xsp zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11 virtual/kernel \
${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad liba52 lame', d)}"
RDEPENDS = "mplayer-common"
@@ -24,6 +24,9 @@ SRC_URI = "svn://svn.mplayerhq.hu/mplayer;module=trunk \
file://mru-neon-vector-fmul.diff;patch=1 \
file://configh \
file://configmak \
+ file://omapfb.patch;patch=1 \
+ file://vo_omapfb.c \
+ file://yuv.S \
"
# This is required for the collie machine only as all stacks in that
@@ -42,7 +45,7 @@ RCONFLICTS_${PN} = "mplayer-atty"
RREPLACES_${PN} = "mplayer-atty"
PV = "0.0+1.0rc2+svnr${SRCREV}"
-PR = "r7"
+PR = "r8"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_armv7a = "1"
@@ -57,6 +60,9 @@ FILES_mencoder = "${bindir}/mencoder"
inherit autotools pkgconfig
+# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
+STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
+
EXTRA_OECONF = " \
--prefix=/usr \
--mandir=${mandir} \
@@ -176,8 +182,8 @@ EXTRA_OECONF = " \
EXTRA_OECONF_append_arm = " --disable-decoder=vorbis_decoder \
--disable-encoder=vorbis_encoder"
-EXTRA_OECONF_append_armv6 = " --enable-armv6 "
-EXTRA_OECONF_append_armv7a = "--enable-armv6 "
+EXTRA_OECONF_append_armv6 = " --enable-armv6"
+EXTRA_OECONF_append_armv7a = " --enable-armv6"
#build with support for the iwmmxt instruction and pxa270fb overlay support (pxa270 and up)
@@ -201,6 +207,11 @@ do_configure() {
sed -i 's|/usr/\S*include[\w/]*||g' ${S}/configure
sed -i 's|/usr/\S*lib[\w/]*||g' ${S}/configure
+ cp ${WORKDIR}/yuv.S ${S}/libvo
+ cp ${WORKDIR}/vo_omapfb.c ${S}/libvo
+ cp ${STAGING_KERNEL_DIR}/arch/arm/plat-omap/include/mach/omapfb.h ${S}/libvo/omapfb.h || true
+ cp ${STAGING_KERNEL_DIR}/include/asm-arm/arch-omap/omapfb.h ${S}/libvo/omapfb.h || true
+
./configure ${EXTRA_OECONF}
cat ${WORKDIR}/configh >> ${S}/config.h