summaryrefslogtreecommitdiff
path: root/packages/mplayer/mplayer_svn.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-07-24 09:58:36 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-07-24 09:58:36 +0000
commit42df964ebd54be4cbba0e9f880debf5d2aea7fef (patch)
treed63ea8e26bd023bcf1d9d1955827e7ef52f27e20 /packages/mplayer/mplayer_svn.bb
parentd544f55d1e6e8b0b3fc3e594fce9db67670291de (diff)
packages/mplayer/* : remove the now obsolete versions of mplayer and
mplayer-atty. Cleaning up loose patches and stuff. Update svn version in line with latest release version.
Diffstat (limited to 'packages/mplayer/mplayer_svn.bb')
-rw-r--r--packages/mplayer/mplayer_svn.bb151
1 files changed, 128 insertions, 23 deletions
diff --git a/packages/mplayer/mplayer_svn.bb b/packages/mplayer/mplayer_svn.bb
index 7af431430b..2a37efe3c6 100644
--- a/packages/mplayer/mplayer_svn.bb
+++ b/packages/mplayer/mplayer_svn.bb
@@ -2,18 +2,21 @@ DESCRIPTION = "Open Source multimedia player."
SECTION = "opie/multimedia"
PRIORITY = "optional"
HOMEPAGE = "http://www.mplayerhq.hu/"
-DEPENDS = "virtual/libsdl libmad zlib libpng jpeg mplayer-common"
+DEPENDS = "virtual/libsdl libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame"
RDEPENDS = "mplayer-common"
LICENSE = "GPL"
SRC_URI = "svn://svn.mplayerhq.hu/;module=mplayer \
file://vo_w100.c \
file://vo_w100_api.h \
file://vo_w100_fb.h \
- file://Makefile.patch;patch=1 \
+ file://Makefile-codec-cfg.patch;patch=1 \
file://w100-configure.patch;patch=1 \
file://w100-Makefile.patch;patch=1 \
file://w100-video_out.patch;patch=1 \
- file://w100-mplayer.patch;patch=1"
+ file://w100-mplayer.patch;patch= \
+ file://libmpdemux-ogg-include-svn.patch;patch=1 \
+ file://libmpcodecs-ogg-include.patch;patch=1 \
+ file://pld-onlyarm5.patch;patch=1"
MAINTAINER="Graeme Gregory <dp@xora.org.uk>"
RCONFLICTS_${PN} = "mplayer-atty"
@@ -34,30 +37,132 @@ PACKAGES =+ "mencoder"
FILES_${PN} = "${bindir}/mplayer"
FILES_mencoder = "${bindir}/mencoder"
-inherit autotools
+inherit autotools pkgconfig
EXTRA_OECONF = " \
--prefix=/usr \
- --mandir=${mandir} \
+ --mandir=${mandir} \
--target=${TARGET_SYS} \
- \
- --enable-mencoder \
- --disable-gui \
- --enable-largefiles \
- --disable-linux-devfs \
- --disable-lirc \
- --disable-lircc \
- --disable-tv \
- --enable-rtc \
- --disable-smb \
- --disable-win32 \
- \
- --enable-tremor-low \
- --disable-mp3lib \
- \
- --disable-x11 \
- --enable-sdl \
- --enable-fbdev "
+ \
+ --enable-mencoder \
+ --disable-gui \
+ --enable-largefiles \
+ --disable-linux-devfs \
+ --disable-lirc \
+ --disable-lircc \
+ --disable-joystick \
+ --disable-vm \
+ --disable-xf86keysym \
+ --disable-tv \
+ --disable-tv-v4l \
+ --disable-tv-v4l2 \
+ --disable-tv-bsdbt848 \
+ --enable-rtc \
+ --enable-network \
+ --disable-winsock2 \
+ --disable-smb \
+ --disable-live \
+ --disable-dvdread \
+ --disable-mpdvdkit \
+ --disable-cdparanoia \
+ --enable-freetype \
+ --disable-unrarlib \
+ --disable-menu \
+ --enable-sortsub \
+ --disable-fribidi \
+ --disable-enca \
+ --disable-macosx \
+ --disable-macosx-finder-support \
+ --disable-macosx-bundle \
+ --disable-ftp \
+ --disable-vstream \
+ \
+ --disable-gif \
+ --enable-png \
+ --enable-jpeg \
+ --disable-libcdio \
+ --enable-liblzo \
+ --disable-win32 \
+ --disable-qtx \
+ --disable-xanim \
+ --disable-real \
+ --disable-xvid \
+ --disable-x264 \
+ \
+ --disable-libavutil_so \
+ --disable-libavcodec_so \
+ --disable-libavformat_so \
+ --disable-libpostproc_so \
+ --disable-libfame \
+ \
+ --enable-tremor-low \
+ \
+ --disable-speex \
+ --disable-theora \
+ --disable-faac \
+ --disable-ladspa \
+ --disable-libdv \
+ --enable-mad \
+ --disable-toolame \
+ --disable-twolame \
+ --disable-xmms \
+ --disable-mp3lib \
+ --disable-libdts \
+ --enable-libmpeg2 \
+ --disable-musepack \
+ --disable-amr_nb \
+ --disable-amr_nb-fixed \
+ --disable-amr_wb \
+ \
+ --disable-gl \
+ --disable-dga \
+ --disable-vesa \
+ --disable-svga \
+ --enable-sdl \
+ --disable-aa \
+ --disable-caca \
+ --disable-ggi \
+ --disable-ggiwmh \
+ --disable-directx \
+ --disable-dxr2 \
+ --disable-dxr3 \
+ --disable-dvb \
+ --disable-dvbhead \
+ --disable-mga \
+ --disable-xmga \
+ --disable-xv \
+ --disable-xvmc \
+ --disable-vm \
+ --disable-xinerama \
+ --disable-x11 \
+ --enable-fbdev \
+ --disable-mlib \
+ --disable-3dfx \
+ --disable-tdfxfb \
+ --disable-s3fb \
+ --disable-directfb \
+ --disable-zr \
+ --disable-bl \
+ --disable-tdfxvid \
+ --disable-tga \
+ --disable-pnm \
+ --disable-md5sum \
+ \
+ --enable-alsa \
+ --enable-ossaudio \
+ --disable-arts \
+ --disable-esd \
+ --disable-polyp \
+ --disable-jack \
+ --disable-openal \
+ --disable-nas \
+ --disable-sgiaudio \
+ --disable-sunaudio \
+ --disable-win32waveout \
+ --enable-select \
+ \
+ --disable-runtime-cpudetection \
+ "
EXTRA_OECONF_append_c7x0 = " --enable-w100 "