summaryrefslogtreecommitdiff
path: root/packages/mplayer/mplayer_1.0pre8.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-06-21 10:16:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-21 10:16:24 +0000
commitc42d24b5fa03ee99ee73030dd09e93d6dd1eb14a (patch)
tree6ba74b496993ce3d65e2c41e0114810ad8d06573 /packages/mplayer/mplayer_1.0pre8.bb
parent74703c393c14c2e7d357942fa2739fb703a91465 (diff)
parentdf74e8c851289bb212fd2d7ca4a16ee1c143a81b (diff)
merge of c5acd74e482d1e7de50bea58a79d8784225f2e5e
and f44ffed4d1c961106d82ea95f9bb41d70cd60e66
Diffstat (limited to 'packages/mplayer/mplayer_1.0pre8.bb')
-rw-r--r--packages/mplayer/mplayer_1.0pre8.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/packages/mplayer/mplayer_1.0pre8.bb b/packages/mplayer/mplayer_1.0pre8.bb
new file mode 100644
index 0000000000..a55c59dc96
--- /dev/null
+++ b/packages/mplayer/mplayer_1.0pre8.bb
@@ -0,0 +1,71 @@
+DESCRIPTION = "Open Source multimedia player."
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.mplayerhq.hu/"
+DEPENDS = "virtual/libsdl libmad zlib libpng jpeg mplayer-common"
+RDEPENDS = "mplayer-common"
+LICENSE = "GPL"
+SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
+ file://vo_w100.c \
+ file://vo_w100_api.h \
+ file://vo_w100_fb.h \
+ file://Makefile.patch;patch=1 \
+ file://w100-configure.patch;patch=1 \
+ file://w100-Makefile.patch;patch=1 \
+ file://w100-video_out.patch;patch=1 \
+ file://w100-mplayer.patch;patch=1"
+
+MAINTAINER="Graeme Gregory <dp@xora.org.uk>"
+RCONFLICTS_${PN} = "mplayer-atty"
+RREPLACES_${PN} = "mplayer-atty"
+PR = "r0"
+
+PARALLEL_MAKE = ""
+
+DEPENDS_append_c7x0 = " sharp-aticore-oss"
+
+S = "${WORKDIR}/MPlayer-${PV}"
+
+PACKAGES =+ "mencoder"
+
+FILES_${PN} = "${bindir}/mplayer"
+FILES_mencoder = "${bindir}/mencoder"
+
+inherit autotools
+
+EXTRA_OECONF = " \
+ --prefix=/usr \
+ --mandir=${mandir} \
+ --target=${TARGET_SYS} \
+ \
+ --enable-mencoder \
+ --disable-gui \
+ --enable-largefiles \
+ --disable-linux-devfs \
+ --disable-lirc \
+ --disable-lircc \
+ --disable-tv \
+ --enable-rtc \
+ --disable-smb \
+ --disable-win32 \
+ \
+ --enable-tremor-low \
+ --disable-mp3lib \
+ \
+ --disable-x11 \
+ --enable-sdl \
+ --enable-fbdev "
+
+EXTRA_OECONF_append_c7x0 = " --enable-w100 "
+
+do_configure() {
+ cp ${WORKDIR}/vo_w100.c ${S}/libvo
+ cp ${WORKDIR}/vo_w100_api.h ${S}/libvo
+ cp ${WORKDIR}/vo_w100_fb.h ${S}/libvo
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake
+}
+