summaryrefslogtreecommitdiff
path: root/packages/mplayer/mplayer_1.0pre6a.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2005-04-05 13:24:10 +0000
committerGraeme Gregory <dp@xora.org.uk>2005-04-05 13:24:10 +0000
commit4b8985e828204f078cc614968373b3fbb18661de (patch)
treebfc406c15b86328e5a2d6638b5f4561597037c45 /packages/mplayer/mplayer_1.0pre6a.bb
parent95f21933116fadf7aa7e1fdf0e3be7d2cf961bb3 (diff)
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into cimmeria.(none):/home/dp/zaurus/openembedded 2005/04/05 13:23:47+00:00 (none)!XorA Small compilation fix for libsdl-qpe and enebale vidix for c7x0 BKrev: 4252917aqjieAZnx9auBszMD8QSPaQ
Diffstat (limited to 'packages/mplayer/mplayer_1.0pre6a.bb')
-rw-r--r--packages/mplayer/mplayer_1.0pre6a.bb92
1 files changed, 92 insertions, 0 deletions
diff --git a/packages/mplayer/mplayer_1.0pre6a.bb b/packages/mplayer/mplayer_1.0pre6a.bb
index e69de29bb2..a8392aadb3 100644
--- a/packages/mplayer/mplayer_1.0pre6a.bb
+++ b/packages/mplayer/mplayer_1.0pre6a.bb
@@ -0,0 +1,92 @@
+DESCRIPTION = "Open Source multimedia player."
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.mplayerhq.hu/"
+DEPENDS = "virtual/libsdl libmad tremor libogg libvorbis zlib libpng jpeg"
+LICENSE = "GPL"
+SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
+ file://Makefile.patch;patch=1 \
+ file://sdl.patch;patch=0 \
+ file://zlib.patch;patch=0 "
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+PARALLEL_MAKE = ""
+
+DEPENDS_c7x0 += "sharp-aticore"
+PACKAGE_ARCH_c7x0 = "${MACHINE_ARCH}"
+SRC_URI_append_c7x0 = "file://mplayer-w100_1.0pre3.1.modified.diff;patch=1 \
+ file://Makefile-vidix.patch;patch=0 "
+
+S = "${WORKDIR}/MPlayer-${PV}"
+
+PACKAGES =+ "postproc postproc-dev"
+
+FILES_${PN} = "${bindir}/mplayer ${libdir}/mplayer/vidix/w100_vid.so"
+
+FILES_postproc = " ${libdir}/libpostproc.so.0.0.0 ${libdir}/libpostproc.so.0"
+FILES_postproc-dev = " ${includedir}/postproc/postprocess.h ${libdir}/libpostproc.so ${libdir}/libpostproc.a"
+
+inherit autotools
+
+EXTRA_OECONF = " \
+ --prefix=/usr \
+ --mandir=${mandir} \
+ --target=${TARGET_SYS} \
+ --enable-shared-pp \
+ \
+ --disable-win32 \
+ --disable-macosx \
+ --disable-dvdread \
+ --disable-mpdvdkit \
+ --disable-tv \
+ --disable-tv-v4l \
+ --disable-tv-v4l2 \
+ --disable-tv-bsdbt848 \
+ --disable-mencoder \
+ --disable-live \
+ \
+ --enable-dynamic-plugins \
+ --enable-fbdev \
+ --enable-sdl \
+ --with-sdl-config=${STAGING_BINDIR}/sdl-config \
+ \
+ --enable-mad \
+ --enable-tremor \
+ --enable-vorbis \
+ \
+ --enable-ossaudio \
+ \
+ --enable-rtc \
+ \
+ --with-extralibdir=${STAGING_LIBDIR} "
+
+EXTRA_OECONF_append_corgi = " --enable-vidix "
+EXTRA_OECONF_append_shepherd = " --enable-vidix "
+EXTRA_OECONF_append_husky = " --enable-vidix "
+EXTRA_OECONF_append_c7x0 = " --enable-vidix "
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_install_append () {
+ install -d ${D}${libdir} ${D}${includedir} ${D}${includedir}/postproc
+ install -m 0644 libavcodec/libpostproc/postprocess.h ${D}${includedir}/postproc/
+ oe_libinstall -so -C ${S}/libavcodec/libpostproc libpostproc ${D}${libdir}
+ cp ${S}/libavcodec/libpostproc/libpostproc.so ${D}${libdir}/libpostproc.so.0.0.0
+ cd ${D}${libdir}
+ ln -sf libpostproc.so.0.0.0 libpostproc.so.0
+ ln -sf libpostproc.so.0 libpostproc.so
+}
+
+do_stage () {
+ oe_libinstall -a -so -C libavcodec/libpostproc libpostproc ${STAGING_LIBDIR}
+ cd ${STAGING_LIBDIR}
+ ln -sf libpostproc.so libpostproc.so.0.0.0
+ ln -sf libpostproc.so libpostproc.so.0
+
+ install -d ${STAGING_INCDIR}/postproc
+ install -m 0644 ${S}/libavcodec/libpostproc/postprocess.h ${STAGING_INCDIR}/postproc/postprocess.h
+}
+