summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_2.0.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-12-12 12:23:02 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-12-12 12:23:02 +0000
commita004355ef9e8378dc8e6289c0aff189997c7c6db (patch)
tree055b44e0eaca345fa8ed80f6a0a9a17ab8ea6a67 /packages/mozilla/firefox_2.0.bb
parente59be84f1e7dc42189f2cf51dbf92f5658ae9b9d (diff)
firefox_2.0.bb : add a version 2.0 of the browser. I have fixed problems
in crosscompiling where BUILD_HOST CCFLAGS were set by mozilla makefiles and also a problem where jsautocfg.h crafter for arm was overwritten by BUILD_HOST version during compile. This still SIGILL's on me, hopefully someone will find that problem.
Diffstat (limited to 'packages/mozilla/firefox_2.0.bb')
-rw-r--r--packages/mozilla/firefox_2.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_2.0.bb b/packages/mozilla/firefox_2.0.bb
new file mode 100644
index 0000000000..c8fbccc2bf
--- /dev/null
+++ b/packages/mozilla/firefox_2.0.bb
@@ -0,0 +1,35 @@
+PR = "r1"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1 \
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1"
+
+S = "${WORKDIR}/mozilla"
+DEFAULT_PREFERENCE = "-1"
+
+inherit mozilla
+
+require firefox.inc
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+
+ sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+}
+
+do_stage() {
+
+ install -d ${STAGING_INCDIR}/${P}
+ cd dist/sdk/include
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/${P}/$f
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
+}
+