summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_2.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-12-12 13:02:22 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-12 13:02:22 +0000
commited03ff0e14485d9ce3cc117ea2f1a9921c5234b3 (patch)
tree98c087e7fa7f172254e73d0eb8058d0f810cbdbe /packages/mozilla/firefox_2.0.bb
parentcbb7e96a766595da9f48dd53784e45fe62db7a76 (diff)
parentada8de47c0371621a7906edcc624556f21e785ee (diff)
merge of '14cb91ca9bde319dd1a0b9521a6f7b44c8d5d462'
and 'cb60d14273a3350c9c89ea8f8808936e25a46b3b'
Diffstat (limited to 'packages/mozilla/firefox_2.0.bb')
-rw-r--r--packages/mozilla/firefox_2.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_2.0.bb b/packages/mozilla/firefox_2.0.bb
new file mode 100644
index 0000000000..c8fbccc2bf
--- /dev/null
+++ b/packages/mozilla/firefox_2.0.bb
@@ -0,0 +1,35 @@
+PR = "r1"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1 \
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1"
+
+S = "${WORKDIR}/mozilla"
+DEFAULT_PREFERENCE = "-1"
+
+inherit mozilla
+
+require firefox.inc
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+
+ sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+}
+
+do_stage() {
+
+ install -d ${STAGING_INCDIR}/${P}
+ cd dist/sdk/include
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/${P}/$f
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
+}
+