summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_2.0.0.3.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-21 15:10:44 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-21 15:10:44 +0000
commitfc8bb1b8fad9b45a31b5b1081fb6c8a67d0654db (patch)
treef1b5c7fbadcc5fce748a2dd739c8b6afeef2c5c7 /packages/mozilla/firefox_2.0.0.3.bb
parentcd2035c98bd1995adf7c3df1b73e5f308357e3e3 (diff)
firefox all use autotools_do_stage to populate staging
this is needed to compile plugins against firefox. closes #1612
Diffstat (limited to 'packages/mozilla/firefox_2.0.0.3.bb')
-rw-r--r--packages/mozilla/firefox_2.0.0.3.bb26
1 files changed, 12 insertions, 14 deletions
diff --git a/packages/mozilla/firefox_2.0.0.3.bb b/packages/mozilla/firefox_2.0.0.3.bb
index e1fb5a996d..72c42bc074 100644
--- a/packages/mozilla/firefox_2.0.0.3.bb
+++ b/packages/mozilla/firefox_2.0.0.3.bb
@@ -6,38 +6,36 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/
file://no-xmb.patch;patch=1 \
file://jsautocfg.h \
file://extensions-hack.patch;patch=1 \
- file://security-cross.patch;patch=1 \
- file://jsautocfg-dontoverwrite.patch;patch=1 \
- file://xptcinvoke-arm.patch;patch=1 \
- file://eabi-fix.patch;patch=1 \
- file://eabi-fix2.patch;patch=1 \
- file://eabi-fix3.patch;patch=1 \
- file://linkage-problem.patch;patch=1 \
- "
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://xptcinvoke-arm.patch;patch=1 \
+ file://eabi-fix.patch;patch=1 \
+ file://eabi-fix2.patch;patch=1 \
+ file://eabi-fix3.patch;patch=1 \
+ file://linkage-problem.patch;patch=1 \
+"
S = "${WORKDIR}/mozilla"
DEFAULT_PREFERENCE = "-1"
inherit mozilla
-
require firefox.inc
do_compile_prepend() {
cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
-
sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
}
do_stage() {
-
- install -d ${STAGING_INCDIR}/${P}
+ install -d ${STAGING_INCDIR}/firefox-${PV}
cd dist/sdk/include
+ rm -rf obsolete
headers=`find . -name "*.h"`
for f in $headers
do
- install -D -m 0644 $f ${STAGING_INCDIR}/${P}/$f
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
done
# removes 2 lines that call absent headers
- sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
+ sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
}